Stuck Tasks

Discussion in 'ISPConfig 3 Priority Support' started by DantePasquale, May 25, 2021 at 5:51 PM.

  1. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Hi, I kind of screwed up. I have ISPConfig running as a standalone email server. I was following the tutorials on adding the Let's Encrypt certs to the mail config and tried to create 2 websites after enabling Web Server.
    Now the tasks are stuck and I can't do a simple thing, like update a mail filter I screwed up.
    Not sure how to proceed, I disabled the Web Server but that is stuck too!
    • Update DNS zone: 8
    • Update email user: 1
    • Update server settings: 1
    • Create new website: 2
    • Update website settings: 3
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  3. DantePasquale

    DantePasquale Member HowtoForge Supporter

    [email protected]:~# /usr/local/ispconfig/server/server.sh
    25.05.2021-14:10 - WARNING - There is already a lockfile set, but no process running with this pid (7679). Continuing.
    25.05.2021-18:10 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    25.05.2021-18:10 - DEBUG - Found 17 changes, starting update process.
    25.05.2021-18:10 - DEBUG - Calling function 'ssl' from plugin 'nginx_plugin' raised by event 'web_domain_insert'.
    25.05.2021-18:10 - DEBUG - Calling function 'insert' from plugin 'nginx_plugin' raised by event 'web_domain_insert'.
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client0/web5' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client0/web5' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: cp '/usr/local/ispconfig/server/conf/error/en/'* '/var/www/clients/client0/web5/web//error/' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chmod -R a+r '/var/www/clients/client0/web5/web//error/' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chmod -R a+r '/var/www/clients/client0/web5/web//' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: df -T '/var/www/clients/client0/web5'|awk 'END{print $2,$NF}' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: which 'setquota' 2> /dev/null - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: setquota -u 'web5' '0' '0' 0 0 -a &> /dev/null - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: setquota -T -u 'web5' 604800 604800 -a &> /dev/null - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chown -R 'web5':'client0' '/var/www/clients/client0/web5/web/' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chown 'web5':'client0' '/var/www/clients/client0/web5/web/' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client0/web5' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: usermod --groups sshusers 'web5' 2>/dev/null - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client0/web5' - return code: 0
    25.05.2021-18:10 - DEBUG - SSL Disabled. mail.cocoanet.us
    25.05.2021-18:10 - DEBUG - safe_exec cmd: nginx -V 2>&1 | grep 'built with OpenSSL' | sed 's/.*built\([a-zA-Z ]*\)OpenSSL \([0-9.]*\).*/\2/' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: nginx -V 2>&1 | grep 'running with OpenSSL' | sed 's/.*running\([a-zA-Z ]*\)OpenSSL \([0-9.]*\).*/\2/' - return code: 0
    25.05.2021-18:10 - DEBUG - safe_exec cmd: which 'nginx' 2> /dev/null - return code: 0
    25.05.2021-18:10 - DEBUG - Enable TLS 1.3 for: mail.cocoanet.us
    25.05.2021-18:10 - DEBUG - Writing the vhost file: /etc/nginx/sites-available/mail.cocoanet.us.vhost
    25.05.2021-18:10 - DEBUG - Removing symlink: /etc/nginx/sites-enabled/100-mail.cocoanet.us.vhost->/etc/nginx/sites-available/mail.cocoanet.us.vhost
    25.05.2021-18:10 - DEBUG - Creating symlink: /etc/nginx/sites-enabled/100-mail.cocoanet.us.vhost->/etc/nginx/sites-available/mail.cocoanet.us.vhost
    25.05.2021-18:10 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    25.05.2021-18:10 - DEBUG - Restarting php-fpm: systemctl reload php7.2-fpm.service
    25.05.2021-18:10 - DEBUG - nginx status is: running
    25.05.2021-18:10 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    25.05.2021-18:10 - DEBUG - Checking nginx configuration...
    25.05.2021-18:10 - DEBUG - nginx configuration ok!
    25.05.2021-18:10 - DEBUG - Restarting httpd: systemctl restart nginx.service
    25.05.2021-18:10 - DEBUG - nginx restart return value is: 0
    25.05.2021-18:11 - DEBUG - nginx online status after restart is: running
    25.05.2021-18:11 - DEBUG - Calling function 'ssl' from plugin 'nginx_reverseproxy_plugin' raised by event 'web_domain_insert'.
    25.05.2021-18:11 - DEBUG - Calling function 'insert' from plugin 'nginx_reverseproxy_plugin' raised by event 'web_domain_insert'.
    vlibTemplate Error: Template (nginx_reverseproxy_vhost.conf.master) file not [email protected]:
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Are there still jobs pending?
     
  5. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Yes, it's still showing 17 jobs. I haven't restarted or rebooted anything and honestly I the jobs can go away since the setup of web services did not help with the email certs

    Is there a way to terminate those jobs in a clean manner?
     
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    No, they have to be run to cleanly get through it. What happens when you run the script now?
     
  7. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Same :( I guess I really f'd things up!
     
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    So the exact same output is shown? Can you share it?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Why is that nginx_reverseproxy_plugin running, it's an old and unmaintained plugin? Try to disable it by deleting the symlink in /usr/local/ispconfig/server/plugins-enabled/ folder. Then run server.sh again.
     
    Th0m likes this.
  10. DantePasquale

    DantePasquale Member HowtoForge Supporter

    I removed that plugin and now the script completed

    What else should I check to make sure I didn't screw things up too badly?
     
  11. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Did all jobs go through? If so, all should be fine.
     
  12. DantePasquale

    DantePasquale Member HowtoForge Supporter

    Yes, I'll create a new thread for the email TLS certificate issue. Th0m and Till, thanks for you excellent help as always!
     
  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Alright, let's look into that in a separate thread indeed. No problem :)
     

Share This Page