stuck on default welcome page

Discussion in 'Installation/Configuration' started by jasona, Aug 6, 2011.

  1. jasona

    jasona New Member

    Hi everyone,

    I have installed ISP Config 3 following the perfect install to debian squeeze with no apparent problems. After install, I added a website through the admin console logged in as admin.

    I get the Welcome to your website! page. When I upload a website via ftp I cannot seem to get past this page. If I so to www.domain/sometingelse.html I get a 404. If I rename the index.html and put a different one I get a page that says something along the lines of "your webmaster has not added content"

    I've been searching these boards and google, and pouring over the manual I purchased for several hours and am coming up blank. Can someone point me in the right direction.

    thanks,

    Jason
     
  2. pititis

    pititis Member

    Files must have the right owner and permissions. Can you post a ls -la from your web/ directory??
     
  3. jasona

    jasona New Member

    here it is. This issue happens for any website I create.

    Code:
    root@Websrv1:/var/www/clients/client1/thealvarados.com/web# ls -la
    total 28
    drwx--x--- 5 web1 client1 4096 Aug  6 18:30 .
    drwxr-x--x 6 web1 client1 4096 Aug  6 18:17 ..
    -rw-r--r-- 1 web1 client1  429 Aug  6 18:26 Home.html
    drwxr-xr-x 2 web1 client1 4096 Aug  6 18:17 error
    drwxr-xr-x 5 web1 client1 4096 Aug  6 18:26 htdocs
    -rwxr-xr-- 1 web1 client1 1861 Aug  6 18:17 index.html
    drwxr-xr-x 2 root root    4096 Aug  6 18:17 stats
    root@Websrv1:/var/www/clients/client1/thealvarados.com/web#
    
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    /var/www/clients/client1/thealvarados.com/web has the wrong permissions. Please try
    Code:
    chmod 755 /var/www/clients/client1/thealvarados.com/web
    chmod 755 /var/www/clients/client1/thealvarados.com/
     
  5. jasona

    jasona New Member

    I tried this and it didnt seem to get any different results. Here's what I ran and what ther permissions look like now
    Code:
    root@websrv1:/var/www/clients/client1/thealvarados.com/web# chmod 755 /var/www/clients/client1/thealvarados.com/
    root@websrv1:/var/www/clients/client1/thealvarados.com/web# chmod 755 /var/www/clients/client1/thealvarados.com/web
    root@websrv1:/var/www/clients/client1/thealvarados.com/web# ls -la
    total 28
    drwxr-xr-x 5 web1 client1 4096 Aug  8 10:38 .
    drwxr-xr-x 6 web1 client1 4096 Aug  6 18:17 ..
    -rw-r--r-- 1 web1 client1  429 Aug  6 18:26 Home.html
    drwxr-xr-x 2 web1 client1 4096 Aug  6 18:17 error
    drwxr-xr-x 5 web1 client1 4096 Aug  6 18:26 htdocs
    -rwxr-xr-- 1 web1 client1 1861 Aug  6 18:17 index.html
    drwxr-xr-x 2 root root    4096 Aug  7 00:30 stats
    root@websrv1:/var/www/clients/client1/thealvarados.com/web#
    
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The previous permissions were correct, so there was no need to change them. You get the default index pahe bevcause the new index page you uploaded has a wrong name.

    Please deleete the file index.html that is currently in the web directory and rename you "Home.htm" page to "index.html". On Linux servers, the homepage is named index.htm or index.html and not Home.htm like on windows servers. Additionally, it matters on Linux if you bame a file in upper or Loewercaee as these are different filenames. So it is recommended that you name you files alwas lowercase.
     
  7. jasona

    jasona New Member

    Thanks for the responese. That was one of the steps I tried. What I was doing ws renaming index.html to _index.html. In this instance did what you recommended and now the page says:

    Code:
    This site is under development
     This is a default template, indicating that the webmaster has not yet uploaded a Web site to the server.
     
    For information on how to build or upload a site, please visit your web hosting company's site.

    Any ideas?

    -Jason
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, so the text that you see in the browser has changed? Then you did the right thing and renamed the correct page.
     
  9. jasona

    jasona New Member

    The text did change. But it is now some sort of default webpage from apache or ispconfig? It's definately not the page that was created.

    It has the text above, plus like a relate items search page.
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post a screenshot of that page. No default page from ispconfig has a search function inside.
     
  11. jasona

    jasona New Member

    forgot to attach
     
    Last edited: Aug 8, 2011
  12. jasona

    jasona New Member

    trying again
     

    Attached Files:

  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The page that you see there is a parking page from a domain registration company or a similar site. It is unlikely that this page is on your server (if you havent uploaded it yourself).

    There are 2 likely options:

    1) The IP address of your domain does not point to the server yet. You can test this on your workstation by using the ping command:

    ping www.yourdomain.com

    ping should then shwo the IP address of your server. If you dont see the IP of your server, then you have to correct the DNS Records of your domain.

    2) the other option is that you might have misspelled the domain name.
     
  14. jasona

    jasona New Member

    The site was registered at godaddy, and thats def not a godaddy parking page.

    name servers are point at ns1.cbccnet.com and ns2(ispconfig server)
    ping the name server, and I get the right IP responding

    The dns config in ispconfig appears correct.

    pinging www.thealvarados.com and thealvarados.com checks out as well.

    spelling appears to be correct across the board.

    I get this parking page if I use a different index.html from the default ispconfig page.

    When I did the install I used the Perfect install process for Debian 6, and the ISPConfig install process from the manual. No errors. The only deviation I made was to install the monocomplete package. But on a different server I had the same issues without mono.

    I also want to thank you for working me through some of this, i do appreciate it. Are there any other things I can check? Being new to linux and ISPConfig I am kinda stuck.

    jason
     
  15. jasona

    jasona New Member

    A little more info that I found.

    I create a very basix html doc, called it index.html. And boom, the site pops up as advertised. After more picking the website does the same thing if I open it from windows explorer on my box. So I guess ISP config is working as advertised.

    Now on to figuring out how to fix this...:mad:
     
  16. jasona

    jasona New Member

    I am all sorted. Turned out that the "actual" index.html file was buried in a subfolder.

    This appears to be a great community. I was really impressed at how easily I could go from no real linux knowledge to have a working web hosting server.

    Thanks again.

    Jason
     

Share This Page