stuck in upgrade hell

Discussion in 'Server Operation' started by Ovidiu, May 11, 2013.

  1. Ovidiu

    Ovidiu Active Member

    Tried to upgrade from Debian squeeze to wheezy and am stuck. Read and tried following a couple of tutorials including the one available here on howtoforge.

    Currently getting this:

    using apt-get -f install suggests:

    0 upgraded, 0 newly installed, 289 to remove and 0 not upgraded.
    5 not fully installed or removed.
    After this operation, 461 MB disk space will be freed.

    So I did not go forward with that.

    Any hints? Google only gives me 2 viable results and both have no real solution.
  2. Ovidiu

    Ovidiu Active Member

    making slowly progress:

    - edited my sources list, put it all back to SQUEEZE then tried this:


    THEN using this tutorial:

    I changes my sources to match WHEEZY then did an apt-get upgrade which resulted in:

    did apt-get upgrade again and saw this:

    YES, I did use dotdeb at some stage so I removed mysql-client-core-5.5:

    I followed up with an apt-get dist-upgrade and was told all is well but:

    after going through with this, I hit an error which I missed copy/pasting saying something about some libc library needing a 2.6 kernel and I am supposed to add some "LENNY" sources to my sources list but Lenny is way outdated, WTF?

    so currently I'm back to this:

    and then I tried this which brings me back to my original libc6 problem so I guess I'll just have ot go all the way back to squeeze !?

  3. Ovidiu

    Ovidiu Active Member

    This didn't give any errors apparently so I started it:

    BUT it still resulted in one:

    So it looks like I need to upgrade my kernel:
  4. Ovidiu

    Ovidiu Active Member

    Found a possible explanation for this but need confirmation: this server is a small VPS from Server4You and I "think" its a XEN VPS so I cannot upgrade my kernel unless they upgrade the host kernel or am I wrong here? Will contact support and ask.

Share This Page