String could not be parsed as XML

Discussion in 'ISPConfig 3 Priority Support' started by churbz, Oct 9, 2018.

  1. churbz

    churbz New Member HowtoForge Supporter

    Greetings. I am a current How To Forge subscriber.

    I seem to have a consistent problem with the APS Installer/Update Package List failing with "String could not be parsed as XML" regardless of the OS (tried Debian 9.x, Ubuntu 18.04). The version of ISPConfig is 3.1 (latest) installed yesterday. Current OS build is Ubuntu 18.04 patched current as of yesterday. I've even tried the VM OVF/OVA version and the problem persists. This is MariaDB and Apache using the perfect server tutorial on the Ubuntu 18.04 subject (PHP 7.2).

    I have searched threads with the above subject keywords and can't seem to find a resolution as most suggestions are for older versions. At a minimum, it is Wordpress that is needed and I'm sure there would be others if I could get a complete package list to select from. There are times that I can get two pages and times that I'll get six pages to select from (based on different build attempts as there have been many). However Wordpress is never contained in the list. I have yet to get a stable working solution to place into production. With the hours spent trying to get a production server up and running, I could have paid for multiple years on a commercial platform, time is money.

    I continue to have high hopes to utilize the product but can never seem to get the packages to work. I really don't want a work around since automation is the key to keeping systems current and secure, IMHO.

    Please assist.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The aps packages and the package list is from apscatalog.com. I just used the Debian 9 ISPConfig Vm from howtoforge. started it, clicked on update packagelist and the list gets loaded fine (takes quite a while, so don't interrupt it and don't switch to another page) and the list then contains wordpress, see attached screenshot. So maybe there is a problem to access the apscatalog.com servers from your location. Btw. the builtin app installer from apscatlog.com is not the only app install solution for ISPConfig, you can also use the one from https://www.softaculous.com/softaculous/ instead.
     

    Attached Files:

  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  4. churbz

    churbz New Member HowtoForge Supporter

    Thanks for the suggestions. My inconclusive findings follow:

    This is a new clean installation of Ubuntu 18.04.1. It is a VM running on VMware ESXi, 6.5.0, 10175896.


    Checked that php-xml is installed as per the following:

    apt list php7* | grep "installed"
    php7.2/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 all [installed]
    php7.2-bz2/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed,automatic]
    php7.2-cgi/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-cli/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-common/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-curl/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-fpm/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-gd/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-imap/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-intl/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-json/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed,automatic]
    php7.2-mbstring/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-mysql/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-opcache/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-pspell/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-readline/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed,automatic]
    php7.2-recode/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-soap/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-sqlite3/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-tidy/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-xml/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed,automatic]
    php7.2-xmlrpc/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]
    php7.2-xsl/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 all [installed]
    php7.2-zip/bionic-updates,bionic-security,now 7.2.10-0ubuntu0.18.04.1 amd64 [installed]

    apt list php-* | grep "installed"
    php-apcu/bionic,now 5.1.9+4.0.11-1build1 amd64 [installed]
    php-apcu-bc/bionic,now 1.0.3-2ubuntu2 amd64 [installed,automatic]
    php-auth-sasl/bionic,now 1.0.6-3 all [installed,automatic]
    php-bz2/bionic,now 1:7.2+60ubuntu1 all [installed,automatic]
    php-common/bionic,now 1:60ubuntu1 all [installed,automatic]
    php-gettext/bionic,now 1.0.12-0.1 all [installed]
    php-imagick/bionic,now 3.4.3~rc2-2ubuntu4 amd64 [installed]
    php-mail-mime/bionic,now 1.10.2-0.1 all [installed,automatic]
    php-memcache/bionic,now 3.0.9~20160311.4991c2f-5build2 amd64 [installed]
    php-net-sieve/bionic,now 1.4.1-1 all [installed]
    php-net-smtp/bionic,now 1.8.0-1 all [installed,automatic]
    php-net-socket/bionic,now 1.0.14-2 all [installed,automatic]
    php-pear/bionic,now 1:1.10.5+submodules+notgz-1ubuntu1 all [installed]
    php-php-gettext/bionic,now 1.0.12-0.1 all [installed,automatic]
    php-phpseclib/bionic,now 2.0.9-1 all [installed,automatic]
    php-soap/bionic,now 1:7.2+60ubuntu1 all [installed]
    php-tcpdf/bionic,now 6.2.13+dfsg-1ubuntu1 all [installed,automatic]
    php-xml/bionic,now 1:7.2+60ubuntu1 all [installed,automatic]

    Nothing exciting here.

    wget -q -O htf-common-issues.php "http://gitplace.net/pixcept/ispconfig-tools/raw/stable/htf-common-issues.php" && php -q htf-common-issues.php --debug

    ##### SERVER #####
    IP-address (as per hostname): 172.16.1.251
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1dev

    ##### VERSION CHECK #####

    [INFO] php (cli) version is 7.2.10-0ubuntu0.18.04.1

    ##### PORT CHECK #####

    ##### MAIL SERVER CHECK #####

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Apache 2 (PID 1723)
    [INFO] I found the following mail server(s):
    Postfix (PID 1909)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 958)
    [INFO] I found the following imap server(s):
    Dovecot (PID 958)
    [INFO] I found the following ftp server(s):
    PureFTP (PID 1987)

    ##### LISTENING PORTS #####
    (only ()
    Local (Address)
    0.0.0.0:21 (1987/pure-ftpd)
    172.16.1.251:53 (1091/named)
    127.0.0.1:53 (1091/named)
    127.0.0.53:53 (864/systemd-resolve)
    0.0.0.0:22 (1422/sshd)
    0.0.0.0:25 (1909/master)
    127.0.0.1:953 (1091/named)
    0.0.0.0:993 (958/dovecot)
    0.0.0.0:995 (958/dovecot)
    127.0.0.1:10023 (1727/postgrey)
    127.0.0.1:10024 (1820/amavisd-new)
    127.0.0.1:10025 (1909/master)
    127.0.0.1:10026 (1820/amavisd-new)
    127.0.0.1:10027 (1909/master)
    0.0.0.0:587 (1909/master)
    127.0.0.1:11211 (1156/memcached)
    0.0.0.0:110 (958/dovecot)
    0.0.0.0:143 (958/dovecot)
    0.0.0.0:465 (1909/master)
    :::21 (1987/pure-ftpd)
    :::53 (1091/named)
    :::22 (1422/sshd)
    :::25 (1909/master)
    ::1:953 (1091/named)
    :::443 (1723/apache2)
    :::993 (958/dovecot)
    :::995 (958/dovecot)
    ::1:10023 (1727/postgrey)
    ::1:10024 (1820/amavisd-new)
    :::3306 (1617/mysqld)
    ::1:10026 (1820/amavisd-new)
    :::587 (1909/master)
    :::110 (958/dovecot)
    :::143 (958/dovecot)
    :::8080 (1723/apache2)
    :::80 (1723/apache2)
    :::465 (1909/master)
    :::8081 (1723/apache2)

    ##### IPTABLES #####
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    f2b-pure-ftpd tcp -- 0.0.0.0/0 0.0.0.0/0 multiport dports 21

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain f2b-pure-ftpd (1 references)
    target prot opt source destination
    RETURN all -- 0.0.0.0/0 0.0.0.0/0
     
  5. churbz

    churbz New Member HowtoForge Supporter

    Till,

    First thanks for the amazing efforts you put forth on the application and site. I can imagine the hours spent and it reflects similar to the 80 hours I work per week.

    When I tried firing up the VM and then doing the surgery to change from the DE to US keyboard layout and renumbering the network to work within my infrastructure and then updating the nearly year old image, I had the same results.

    I'll give it another go but this time without doing any updates and post my results. I tried both the Debian and Ubuntu VM's and I don't remember which required more effort to get running but I remember one was ISPConfig 3.1.3 and after the update everything was mostly broken. However, I will do it once more this time taking better notes and report my findings.

    Have you written a guide to include softaculous within ISPConfig? I use it in some other hosting services and it does a fairly good job and if it is an alternative, then I would surly consider using it instead.

    Thanks again.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Really strange, I never had a single issue in updating ISPConfig in one of the VM systems in the past years and all I do is running ispconfig_update.sh. But If you let me know in which exact Ubuntu 18.04 or Debian 9 VM the update failed for you, then I'll test it again in that VM.

    Please contact softaculous for instructions on how to install their product.
     

Share This Page