[Stretch] Changing apache document root, php-fpm stops working

Discussion in 'Installation/Configuration' started by SergiX44, Jul 5, 2017.

  1. SergiX44

    SergiX44 Member

    I've recently created a clean installation of ispconfig on debian stretch, and i've a problem with php-fpm. Using the default document root it works without problems, but when i try to override the document root (for example for laravel installations) it stops to work, and show php as plain text. If i switch on fastcgi or mod php it back to work, but not fpm.
    This is how I override the document root in the apache directive box:
    Code:
    DocumentRoot {DOCROOT}/public
     
  2. SergiX44

    SergiX44 Member

    UPDATE:
    Put the full path, instead the DOCROOT it works:
    Code:
    DocumentRoot /var/www/clients/clientX/webX/web/public #working
    DocumentRoot {DOCROOT}/public #not working
    
    Can it be related to some ispconfig/apache settings? On my old Debian Jessie server work also the second one.
    Thanks
     

Share This Page