Strange Pureftpd issue

Discussion in 'Installation/Configuration' started by szepesif, Aug 27, 2013.

  1. szepesif

    szepesif New Member

    I'm using Debian 7 with the latest ISPConfig. Everything works fine, but in the past few days i'm experiencing a strange FTP anomaly. I can log in to the previously created accounts and i can upload/overwrite files but i can't delete them. When i try to do that i get this error message: "550: Could not delete file.ext: Operation not permitted"

    I tried to create an FTP account manually (without the ISPConfig) and the result is the same. But the strangest thing is: It doesn't matter if i chmod the parent folder and the files to 777 the error message is still the same and i can't delete those files via Total Commander or FileZilla. I have to log in to SSH to delete them but it's not a solution because not everyone has root access.

    I did an "ls -la" and the permissions seems fine. I didn't touch the server or the configuration but i did an ISPConfig upgrade when i saw the new version.

    What is wrong here? Can you help me figure it out?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that the option:

    KeepAllFiles yes

    iss et in your pure-ftpd configuration.
  3. szepesif

    szepesif New Member

    Thank you!

    I changed the 'yes' to 'no' in the 'KeepAllFiles' and it solved my problem right away. It's really strange though because i never touched that file. Maybe the ISPConfig update modified it somehow.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not modifying this setting in pure-ftpd.

Share This Page