Strange pure-ftp problem

Discussion in 'Installation/Configuration' started by DarranJones, Oct 26, 2010.

  1. DarranJones

    DarranJones New Member

    Everything looks like it's working fine, I look in the System Log and it shows;

    Oct 26 15:30:11 web pure-ftpd: (?@xx.xx.xx.xx) [INFO] New connection from xx.xx.xx.xx
    Oct 26 15:30:11 web pure-ftpd: (?@xx.xx.xx.xx) [INFO] testclient-test is now logged in

    Unfortunately in the ftp client it says;

    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 15:00. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    USER testclient-test
    331 User testclient-test OK. Password required
    PASS (password not shown)
    230-User testclient-test has group access to: client1 sshusers
    230 OK. Current restricted directory is /
    FEAT
    211-Extensions supported:
    EPRT
    IDLE
    MDTM
    SIZE
    REST STREAM
    MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    MLSD
    ESTP
    PASV
    EPSV
    SPSV
    ESTA
    AUTH TLS
    PBSZ
    PROT
    UTF8
    211 End.
    OPTS UTF8 ON
    550 Access is denied.
    PWD
    257 "/" is your current location
    TYPE A
    200 TYPE is now ASCII
    PASV
    227 Entering Passive Mode (172,16,5,3,248,79)
    MLSD
    550 Access is denied.
    : //

    Not sure why it says everything's going good and then fails right at the last bit.

    Any pointers would be appreciated.

    Darran
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. DarranJones

    DarranJones New Member

    Yeah, I thought it was a firewall issue too (we use ISA2006), but we've checked and you can watch it letting the traffic through. SELinux is also disabled.

    I've also tried setting it to active mode in the ftp client but that says Access Denied too and then keeps trying to reconnect every 10 seconds.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. DarranJones

    DarranJones New Member

    Thanks. As I'm using CentOS 5.5, I changed VerboseLog to yes in /etc/pure-ftpd/pure-ftpd.conf and restarted pure-ftpd. Doesn't appear to be any change in the system log though. Is there a pure-ftp specific one?

    It looks to me like the ftp connection is being made with the server, but then it's saying the ftp account doesn't have access to that directory and so I can't read/write anything. After a while the connection times out and the ftp client says 'Connection closed'.

    I'll use Shell for now. Just a really annoying problem, and I'm definitely no Linux expert =(

    Darran
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Centos uses other files for the pure-ftpd configuration. As far as I know, there is a config file in /etc or so.
     

Share This Page