strange problem [email protected]

Discussion in 'Installation/Configuration' started by marcob, Mar 16, 2009.

  1. marcob

    marcob New Member

    I'm using [email protected] authentication with dovecot/postfix
    POP3/IMAP is working fine. When I try to use squirrelmail/roundcube mail
    I cannot authenticate. I get in the logs:

    Mar 16 13:26:45 weburl-l dovecot: auth(default): pam(_burla.org_alvaro,127.0.0.1): pam_authenticate() failed: User not known to the underlying authentication module

    The strange thing is that on a specific domain (the first I created) it's working with squirrel/roundcube too on all users I create.
    On other domains it's not working.

    Any hints on this?
     
  2. marcob

    marcob New Member

    the one that is working reports:
    dovecot: imap-login: Login: user=<ziopino.org_gheghe>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured

    the one that is not working reports:
    dovecot: auth(default): pam(_burla.org_alvaro,127.0.0.1): pam_authenticate() failed: User not known to the underlying authentication module

    you can see the difference:
    incorrect: _burla.org_alvaro
    it's that _

    the one that is not working is burla.org_alvaro
    it's translated in _burla.org_alvaro

    this happens with both squirrelmail and rounducubemail

    also on roundcubemail logs:
    Authentication for burla.org_alvaro failed (LOGIN): "a001 NO Authentication failed.
    while dovecot reports _burla.org_alvaro

    I' stuck
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats a known problem with these webmal packages as they contain patches to lookup the email address in /etc/postfix/virtusertable which is not compatible with the [email protected] postfix setup. You can try to look into the sources of the webmail applications to deactivate these patches. For roundcube you might ask hans which is the package maintainer, he might be able to tell you which file has to be modified.
     
  4. marcob

    marcob New Member

    For roundcube it seems that setting rcmail_config['virtuser_file'] ='' solve the issue. I'm looking for a fix for squirrelmail
     

Share This Page