Strange mail problem

Discussion in 'Installation/Configuration' started by blocker, Jun 9, 2008.

  1. blocker

    blocker Member

    Hi Forumers,

    i have a strange problem on 1 of my servers running ispconfig 2.2.23 and debian etch

    So here it is:

    1. mail is sent to [email protected], example1.com does not have a mailbox named ebay, and does not have any "catch all" turned on
    2. example2.com does have a mailbox named ebay - [email protected]

    the mail fails to deliver to [email protected] BUT it gets in the mailbox [email protected]

    Does anybody have an idea whats going on?

    Thanks!
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. blocker

    blocker Member

    Unfortunately it is not...

    server FQDN is something like this: server123.server-provider.com. The domain server-provider.com is not hosted on server123. In the the main.cf there is nothing mentioned about the problematic domains: example1.com and example2.com :eek:
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in your main.cf?
     
  5. blocker

    blocker Member

    My main.cf looks so with the comments removed:

    Code:
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    myhostname = server123.server-provider.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names
    unknown_local_recipient_reject_code = 450
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mailname?
     
  7. blocker

    blocker Member

    server123.server-provider.com
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you remove the user prefixes in ISPConfig, and is there a user called ebay in /etc/passwd?
     
  9. blocker

    blocker Member

    YES!!!
    both are true...
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Ok, that's the problem. example1.com and example2.com both point to the same server, and then Postfix sees that there's a user called "ebay" and delivers the mail to his mailbox. The solution is to not disable the user prefixes in ISPConfig...
     

Share This Page