Strange folder permissions from PHP scripts.

Discussion in 'Server Operation' started by FeraTechInc, May 10, 2009.

  1. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    PHP Version - 5.2.4-2ubuntu5.5
    MySQL Version - 5.0.51a-3ubuntu5.4
    Server API Version - apache2handler
    OS Version - Ubuntu 8.10
    ISPConfig 2.2.x

    So several sites that I have use PHP scripts to create folders in an uploads gallery. However, once these folders are created they aren't writable by the site.

    The scripts are set to chmod the folders to 777 but these created folders have the following permissions:

    owner:
    www-data
    permission:
    755

    The owner should be obviously webX where X is the number of the site.
     
  2. bernholdt

    bernholdt Member

    Last edited: May 11, 2009
  3. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    Thank you so much...

    A couple followup questions, how do I check the version of ISPconfig?

    Can I add this with other sites already configured?

    Lastly does it work with ISPConfig 3?
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Tools > Software Version

    Yes.

    ISPConfig 3 supports suPHP out of the box. All you have to do is set up your server using one of the "Perfect Server" guides for ISPConfig 3.
     
  5. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    Thanks for the reply but the howto ended up breaking my server.

    None of the PHP scripts work. I can still access ISPConfig and html pages but when I try to access a PHP site on the server it downloads a PHTML or PHP file...

    Any help would be appreciated.
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Take a look at the logs.
     
  7. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    It works. There was some information missing in the howto.

    I needed to remove php_admin entries from my /etc/apache2/vhosts/Vhosts_ispconfig.conf file.

    Man I hate technology, lol.

    I was getting scarred because I have a very big client that uses a couple of my sites on a daily bases.

    Thanks, I appreciate it.
     
  8. bernholdt

    bernholdt Member

  9. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    Well I got the server back up and running. PHP scripts are running fine.

    However, a new problem. While uploading files was a bit sketchy before. Sometimes it would work and others not. Now uploading doesn't work at all.

    I can't upload anything.

    2 questions, are there some configuration settings that need changing?

    Can whatever I did be simply undone?
     
  10. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    I have tried messing around with suPHP settings to no avail. I can't seem to get any file uploads to work at all.

    Any help would be greatly appreciated. I tried researching the issue and there doesn't seem to be any solution.
     
  11. bernholdt

    bernholdt Member

    Well i wouldnt recomend you to undo it it much more secure this way make sure you have file uploads on in your php ini.
    remember to check both /usr/local/Zend/etc/php.ini & /etc/php5/cgi/conf.d
     

Share This Page