strange error?

Discussion in 'General' started by useranty, Mar 29, 2017.

  1. useranty

    useranty New Member

    Hi everybody!
    I have two sites on my ispconfig 3.1.2 with joomla
    client9 > web71 and client 23 > web72 (set php-fpm both) and I got error ones on one (then two work correct), ones on two (then one is ok) site,
    error examples:
    [Wed Mar 29 20:32:29.842927 2017] [:error] [pid 30490] [client XX.XX.XX.XX:39238] FastCGI: server "/var/www/clients/client23/web72/cgi-bin/php5-fcgi-*-80-XXXXX.pl" stderr: PHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/var/www/clients/client9/web71/web/libraries/vendor/joomla/application/src/AbstractApplication.php) is not within the allowed path(s): (/var/www/clients/client23/web72/web:/var/www/clients/client23/web72/private:/var/www/clients/client23/web72/tmp:/var/www/XXXXX.pl/web:/srv/www/XXXXX.pl/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client9/web71/web/libraries/vendor/composer/ClassLoader.php on line 354

    [Wed Mar 29 20:32:29.842979 2017] [:error] [pid 30490] [client XX.XX.XX.XX:39238] FastCGI: server "/var/www/clients/client23/web72/cgi-bin/php5-fcgi-*-80-XXXXX.pl" stderr: PHP message: PHP Fatal error: Class 'Joomla\\Application\\AbstractApplication' not found in /var/www/clients/client23/web72/web/libraries/joomla/application/base.php on line 23

    [Wed Mar 29 20:56:44.542442 2017] [:error] [pid 32308] [client XX.XX.XX.XX:50282] FastCGI: server "/var/www/clients/client9/web71/cgi-bin/php5-fcgi-*-80-ZZZZZZZ.pl" stderr: PHP message: PHP Warning: file_exists(): open_basedir restriction in effect. File(/var/www/clients/client23/web72/web/libraries/vendor/composer/../joomla/application/src/AbstractApplication.php) is not within the allowed path(s): (/var/www/clients/client9/web71/web:/var/www/clients/client9/web71/private:/var/www/clients/client9/web71/tmp:/var/www/ZZZZZZZ.pl/web:/srv/www/ZZZZZZZ.pl/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin) in /var/www/clients/client23/web72/web/libraries/vendor/composer/ClassLoader.php on line 354

    [Wed Mar 29 20:56:44.542498 2017] [:error] [pid 32308] [client XX.XX.XX.XX:50282] FastCGI: server "/var/www/clients/client9/web71/cgi-bin/php5-fcgi-*-80-ZZZZZZZ.pl" stderr: PHP message: PHP Fatal error: Class 'Joomla\\Application\\AbstractApplication' not found in /var/www/clients/client9/web71/web/libraries/joomla/application/base.php on line 23

    and set for one site php: fast-cgi then work without error both. Why is it like that? I check owner files for both sites and restart php-fpm and apache2, and restart vps server does't help.
    What can I check or do?
    j.
    ps. sorry for my poor english
     
    Last edited: Mar 30, 2017
  2. Jesse Norell

    Jesse Norell Well-Known Member

    I may not understand the problem correctly, but if you always have one site that works while the other doesn't, maybe both sites and php-fpm daemons point to the same port and/or socket? If that were the case, whichever fpm daemon started first would work, while the second site failed.
     

Share This Page