Strange Error with UebiMiau.

Discussion in 'Installation/Configuration' started by domh, Oct 7, 2008.

  1. domh

    domh New Member

    Hi there,

    I have the wierdest error with UebiMiau. See below.

    1. If there are no emails in the inbox I cannot send out email. (mail.log does not have any relivant entries...it just says login and logout for the same time)

    2. If I have an email in the inbox I can reply to it and it goes through.
    3. If I have an email in my inbox and i CREATE a new message it goes through.

    If I use an external email program configured for IMAP (I use Windows Live Mail) everything works regardless.

    I look forward for your help.

    Regards,

    Dominic
     
  2. Hans

    Hans Moderator ISPConfig Developer

    Probably you need to enable the Maildir format in ISPConfig.
     
  3. domh

    domh New Member

    Hi there,

    I should have said that this is a Ubuntu 8.04 built with the perfect server script so the maildir option is ticked.

    Cheers.

    Dom
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Does this happen only for new accoutns that have never before received any emails, or only for older accounts that have received emails, but whose mailbox is currently empty?

    If it's only for new accounts, then I guess it's because the Maildir wasn't created. The Maildir is created automatically when the first email arrives, so sending an email to that account should fix the problem.
     
  5. domh

    domh New Member

    Hi Falko

    Yes it is the first time I have set up email to go to the ISPCONFIG box (previously our SME 7.3 box which we are phasing out).

    However once I have an email in the Inbox UebiMiau sends ok. Under all circumstances it receives ok. The sending problem is only with UebiMiau. When I connect to the box via IMAP everything works fine.

    So no problems sending and receiving mail only sending mail via UebiMiau.

    An easy fix it to use squirrel mail?

    Also I will recheck the problem...I upgraded from 2.2.4 to 2.2.6 last night.

    Thanks for your help.

    Dom
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The latest version is 2.2.26.

    So the problem does not occur if you first send an email to a new account and then try to log in?
     
  7. domh

    domh New Member

    Hi there. Whoops yes I have the latest...and yes it does not occur if I email the account first. But as soon as I delete that email and there is nothing in the inbox it is back.

    Regards.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Can you go to the home directory of one of the affected users and post the output of
    Code:
    ls -la
    ?
     
  9. domh

    domh New Member

    Hi there,


    [email protected]:/var/www/web1/user/web1_cath# ls -l
    total 8
    drwx------ 5 web1_cath web1 4096 2008-10-07 21:51 Maildir
    drwxrwxr-x 2 web1_cath web1 4096 2008-10-07 20:49 web
    [email protected]:/var/www/web1/user/web1_cath#
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la Maildir
    ?
     
  11. domh

    domh New Member

    Hi there,

    [email protected]:~# cd /var/www/web1/
    [email protected]:/var/www/web1# ls
    cgi-bin ftp log Maildir phptmp ssl user web
    [email protected]:/var/www/web1# ls -la Maildir
    lrwxrwxrwx 1 root root 36 2008-10-08 21:35 Maildir -> /var/www/web1/user/web1_domh/Maildir

    [email protected]:/var/www/web1/user/web1_domh# ls
    Maildir web
    [email protected]:/var/www/web1/user/web1_domh# ls -la Maildir
    total 100
    drwx------ 6 web1_domh web1 4096 2008-10-07 20:45 .
    drwxr-xr-x 5 web1_domh web1 4096 2008-10-08 21:35 ..
    drwx------ 2 web1_domh web1 4096 2008-10-15 11:16 courierimapkeywords
    -rw-r--r-- 1 web1_domh web1 6 2008-10-07 20:45 courierimapsubscribed
    -rw-r--r-- 1 web1_domh web1 18679 2008-10-15 11:16 courierimapuiddb
    -rw-r--r-- 1 web1_domh web1 19539 2008-10-07 22:01 courierpop3dsizelist
    drwx------ 2 web1_domh web1 36864 2008-10-15 11:51 cur
    drwx------ 2 web1_domh web1 4096 2008-10-15 11:16 new
    drwx------ 2 web1_domh web1 4096 2008-10-15 12:28 tmp
    [email protected]:/var/www/web1/user/web1_domh#


    Thanks!
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Do you see any errors in the mail log and the error log in /root/ispconfig/httpd/logs?
     

Share This Page