Strange email delivery behaviour

Discussion in 'Installation/Configuration' started by zarrelli, Jul 23, 2006.

  1. zarrelli

    zarrelli New Member

    Hi,

    I created a website with one email. And till here, it's all ok, I receive my emails.

    But, on a second site, belonging to one of my friend, he created his email addressers and...all his emails come to my box. In the header of the email I find:

    X-Original-To: dario@xforce.it
    Delivered-To: webxx_xxxxx@zarrelli.org

    I went on RoundCube with his account and I don't see any email in his inbox.
     
  2. zarrelli

    zarrelli New Member

    Strange:


    I went on the zarrelli.org admin site in ispconfig and for the user webxx_xxxxx@zarrelli.org i toggled off the Catch-all options. So, dario@xforce.it is now receiving his emails.

    But, catch-all is meant to catch on one email address all the emails sent to non existent addresses for the same domain, isn't it? So why is it interfering with email from other domains?
     
  3. zarrelli

    zarrelli New Member

    More info:

    I unchecked catch-all on zarrelli.org email address and I checked on the xforce.it address and the email are flowing with no problems. They are redirected only if I check catch-all on the address in zarrelli.org domain
     
  4. till

    till Super Moderator

  5. zarrelli

    zarrelli New Member

    Well, I checked my /etc/postfix/main.cf, but I have no $mydomain entry.
    This is my /etc/postfix/main.cf:

    -------------------------------------------------------

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname = localhost.localdomain
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = zarrelli.org, localhost.localdomain, localhost.localdomain, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names

    -----------------------------------------------

    I never touched this file.
     
  6. falko

    falko Super Moderator

    What's the output of
    Code:
    hostname
    and
    Code:
    hostname -f
    ?

    What's in /etc/hosts and /etc/postfix/virtusertable?
     
  7. zarrelli

    zarrelli New Member

    homeland:~# hostname
    homeland
    homeland:~#

    homeland:~# hostname -f
    localhost.localdomain

    homeland:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost homeland
    88.198.37.43 control.zarrelli.org

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    homeland:~#

    homeland:~# cat /etc/postfix/virtusertable
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    # Version 1.0
    #
    ###################################
    admin@www.zarrelli.org web11_giorgio
    giorgio@www.zarrelli.org web11_giorgio
    web11_giorgio@www.zarrelli.org web11_giorgio
    admin@zarrelli.org web11_giorgio
    giorgio@zarrelli.org web11_giorgio
    web11_giorgio@zarrelli.org web11_giorgio
    dario@www.xforce.it web16_dario
    web16_dario@www.xforce.it web16_dario
    dario@xforce.it web16_dario
    web16_dario@xforce.it web16_dario
     
  8. till

    till Super Moderator

    The hostname localhost.localdomain is not a valid hostname for a server that shall exchange emails with other servers.

    Please change the hostname to e.g.

    echo server1.zarrelli.org > /etc/hostname
    /bin/hostname -F /etc/hostname

    and make sure that server1.zarrelli.org exists and points to your (external) server IP in DNS.
     
  9. zarrelli

    zarrelli New Member

    I did as you told.

    Flagging catchall still make all the emails from other domains to come on my email address.

    Should I erase all the "localhost" and "localhost.localdomain" references in /etc/postfix/main.cf and change them with the new value?
     
  10. till

    till Super Moderator

    Yes, please replace them too and restart postfix afterwards.
     
  11. zarrelli

    zarrelli New Member

    I did and restarted the server. The problem still remain. Here are the new configurations:

    homeland:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost homeland homeland.zarrelli.org control control.zarrelli.org
    88.198.37.43 control control.zarrelli.org homeland homeland.zarrelli.org

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    homeland:~#

    # /etc/aliases
    mailer-daemon: postmaster
    postmaster: root
    nobody: root
    hostmaster: root
    usenet: root
    news: root
    webmaster: root
    www: root
    ftp: root
    abuse: root
    noc: root
    security: root
    root: giorgio@zarrelli.org

    homeland:/etc/postfix# cat main.cf
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname = homeland.zarrelli.org
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    #mydestination = zarrelli.org, localhost.localdomain, localhost.localdomain, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names

    homeland:/etc/postfix# cat local-host-names
    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    homeland.zarrelli.org.localdomain
    localhost.homeland.zarrelli.org.localdomain
    localhost.zarrelli.org.localdomain
    www.zarrelli.org
    www.wavetechnology.it
    www.xforce.it
    wavetechnology.it
    zarrelli.org
    xforce.it
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####homeland:/etc/postfix#

    homeland:/etc/postfix# cat /etc/hostname
    homeland.zarrelli.org

    homeland:/etc/postfix# cat /etc/hostname
    homeland.zarrelli.org
     
  12. zarrelli

    zarrelli New Member

    I forgot...

    homeland:/etc/postfix# hostname
    homeland.zarrelli.org
    homeland:/etc/postfix# hostname -f
    localhost.localdomain
    homeland:/etc/postfix#
     
  13. todvard

    todvard ISPConfig Developer

    try to change your hosts file to look like this:

    homeland:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    88.198.37.43 control.zarrelli.org control homeland.zarrelli.org homeland

    after the change the otput of hostname command should look like this:

    homeland:/etc/postfix# hostname
    homeland.zarrelli.org
    homeland:/etc/postfix# hostname -f
    homeland.zarrelli.org
     
  14. falko

    falko Super Moderator

    You might have to reboot the system, too.
     
  15. redweb

    redweb New Member

    I am having this same exact issue. (Ubuntu 5.10, ISPConfig

    Just upgraded yesterday to 2.2.5 from 2.2.3. I've upgraded before without issue.

    **UPDATE**

    When the catchall is enabled I cannot use a mail client (TBird or outlook) because I get a server timeout error however when I turn off the catchall I can then log in with my email client.

    I've run through suggestions above and my system look to be set up in the same manner as Zarelli and output looks to be good as well.

    I have made other changes yesterday as well. Changed hostname but tested before upgrade and server was functioning. I've gone through postfix walkthrough as described on the perfect setup for 5.10 as well as rechecked DNS (using registrar for DNS)

    --Will be happy to provide logs, files everything but physical access to the server to help resolve this issue.
     
    Last edited: Jul 25, 2006
  16. till

    till Super Moderator

    When you want to send or receive mail?
     
  17. redweb

    redweb New Member

    Yes when I crank up tbird or outlook it won't even let me connect to my mail server as I get the timeout pop-up. Works as it should when I turn off the catchall.
     
  18. falko

    falko Super Moderator

    What's the output of
    Code:
    netstat -tap
    when you can't connect with Outlook or Thunderbird?
     

Share This Page