strange default page

Discussion in 'Installation/Configuration' started by donix, Oct 22, 2010.

  1. donix

    donix New Member

    Hello, I'm running ispconfig 3 on debian. I'm experiencing some strange behavior with it. I have created a few sites and some domains for email.
    I discovered to day, when I visit a email-domain with a web-browser it shows the first website I added to ISPC. I guess it's because the domain is starting with ab(alphabetically the first site). E.g. emaildomain.tld shows ab.domain.tld

    I have some domains who only is used for email and therefore isn't added to "sites" in ISPC. These domains should not show anything when visited by a web-browser.

    How do I change this behavior?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. donix

    donix New Member

    Thanks.. I've tried to add
    <VirtualHost _default_:*>
    DocumentRoot /var/www/default
    to /etc/apache2/sites-available/default and then restarted apache2. It dosen't make a difference
  4. donix

    donix New Member

    I've tried
    <VirtualHost *:80>
      ServerName default
      Redirect 404 /
    <VirtualHost _default_:80>
      Redirect 404 /
    from but it persists loading the first website. I've tried to add it to apache2.conf and also tried as a file in sites-enabled. Can anyone help me?
  5. donix

    donix New Member

    No one? My sites-enabled folder contains a 000-default file - has it something to do with that?
  6. rohitbanerjee

    rohitbanerjee New Member

    AFAMK goes, 000-default is the default vhost. Try the code in 000-default, both in sites-enabled and in sites-available

    Let me know if your problem is solved.
  7. donix

    donix New Member

    I've got more than one IP pointing at my server. I found out that I mixed that up in my vhosts. By fixing this Apache now responds with the default "It works!" when no vhosts is created for a domain pointing at the server

    Thanks for your reply.

Share This Page