Strange Chars!!

Discussion in 'Installation/Configuration' started by QuikeMore, Aug 16, 2006.

  1. QuikeMore

    QuikeMore New Member

    Hello Friends

    I Perfect Setup Fedora core 5 with ispconfig work fine!!

    I migrated my old databases and webpages (php, html, mysql) from Redhat 9 to my new server

    On new server webpages show strange chars (ex. chinese o japs ) on aquoted letter "รก" by example how fix them?:confused:

    any idea

    thanks

    Enrique :rolleyes:
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you include a charset in the HTML head section?
     
  3. QuikeMore

    QuikeMore New Member

    yes i m include charset=iso-8859-1

    my static pages show the strange chars
    and php+mysql pages too

    i tried edit structure and change Collation Column for every field?? (i used phpmyadmin tool) very hard i used spanish collation whats wrong!

    my pages is spanish language

    Quike
     
  4. falko

    falko Super Moderator ISPConfig Developer

    There have always been problems with charsets on RedHat; I thought they were gone on Fedora, but obviously not.

    You could run
    Code:
    su -m [I]apache_user[/I]
    and then run
    Code:
    env
    What's the output?
     
  5. QuikeMore

    QuikeMore New Member

    Hello te output is:

    SSH_AGENT_PID=23426
    HOSTNAME=host.domain.org
    TERM=xterm
    SHELL=/bin/bash
    DESKTOP_STARTUP_ID=
    HISTSIZE=1000
    GTK_RC_FILES=/etc/gtk/gtkrc:/root/.gtkrc-1.2-gnome2
    WINDOWID=37748813
    QTDIR=/usr/lib64/qt-3.3
    QTINC=/usr/lib64/qt-3.3/include
    USER=root
    LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:eek:r=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
    SSH_AUTH_SOCK=/tmp/ssh-xTYvF23381/agent.23381
    GNOME_KEYRING_SOCKET=/tmp/keyring-1mqnjT/socket
    KDEDIR=/usr
    SESSION_MANAGER=local/hostx.delap.org.bo:/tmp/.ICE-unix/23381
    PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
    DESKTOP_SESSION=default
    MAIL=/var/spool/mail/root
    GDM_XSERVER_LOCATION=local
    PWD=/root
    INPUTRC=/etc/inputrc
    LANG=es_ES.UTF-8
    GDMSESSION=default
    SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
    SHLVL=3
    HOME=/root
    GNOME_DESKTOP_SESSION_ID=Default
    LOGNAME=raiz
    CVS_RSH=ssh
    QTLIB=/usr/lib64/qt-3.3/lib
    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ylnvGYvwCP,guid=26d4e444aaa6e5eba214adefbc0ebf00
    LESSOPEN=|/usr/bin/lesspipe.sh %s
    DISPLAY=:0.0
    G_BROKEN_FILENAMES=1
    XAUTHORITY=/root/.xauthgxEsxQ
    COLORTERM=gnome-terminal
    _=/bin/env

    thanks
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You can try to play around with this variable. Maybe change it to en_US or es_ES each time without UTF-8).
     

Share This Page