Strange Behaviour

Discussion in 'Installation/Configuration' started by chrno, Jul 13, 2006.

  1. chrno

    chrno New Member

    For the last couple of months, I've using Apache Directives (Optional): to redirect the website. Annd it has been working great. But today, I noticed that all the apaches directives have been disabled. Does any know why this is happening?

    Code:
    # ServerName www.barclayandmcintyre.co.uk # NOT SUPPORTED!
    # redirect / http://www.londonandgeneral.com/clients/barclay  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    # ServerName barclayandmcintyre.co.uk # NOT SUPPORTED!
    # redirect / http://www.londonandgeneral.com/clients/barclay  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    
    At the moment, I'm just using a backup copy of the /etc/apache2/vhosts/Vhosts_ispconfig.conf (without the # NOT SUPPORTED! lines) to do the redirects.
     
    Last edited: Jul 13, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you disable a module in your Apache configuration?
    The problem could also be that you use ServerName twice, and the ISPConfig writes it a third time in the vhost. It should be used only once in a vhost.
     
  3. chrno

    chrno New Member

    none I haven't touch the apache or the system since I installed it.

    If it's caused by servername, how would you write the apache directives to "forward" to another website in ISPConfig?

    Thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

  5. chrno

    chrno New Member

    I've checked the Apache's documentation and the Vhosts_ispconfig.conf. Seem to be fine.
    See this link and my Vhosts file (you may need to search for "# NOT SUPPORTED!")

    Is it possible to run a SQL query and reenable the URL forwarding? Say:-

    Code:
    Replace "# ServerName" with "Servername"
    Replace "# redirect" with "redirect"
    Replace "# NOT SUPPORTED!" with ""
    
    Any help will be much appreciated! :D
     
    Last edited: Aug 1, 2006
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If I remember you can do text replacements in mysql databases with SQL commands, but I dont remember the exact command. You will find them in the mysql online documentation.

    You can disable the httpd sysntax check in ISPConfig by setting:

    $go_info["server"]["httpd_check"] = 1;

    to:

    $go_info["server"]["httpd_check"] = 0;

    in the config.inc.php file. But this is not recommended as apache will not start anymore if an error occurs.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Have a look at your vhosts:

    Code:
    <VirtualHost 81.29.86.115:80>
    # [B][COLOR="Red"]ServerName[/COLOR][/B] www.badwellashholidaylodges.co.uk # NOT SUPPORTED!
    # redirect / http://www.badwellashlodges.co.uk # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    # ServerName badwellashholidaylodges.co.uk # NOT SUPPORTED!
    # redirect / http://www.badwellashlodges.co.uk # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    #  # NOT SUPPORTED!
    [B][COLOR="Red"]ServerName[/COLOR][/B] www.badwellashholidaylodges.co.uk:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web15/web
    ServerAlias badwellashholidaylodges.co.uk
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web15/log/error.log
    Alias /error/ "/var/www/web15/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web15/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web15/user/$1/web/$3
    </VirtualHost>
    You're using ServerName twice. I guess this is causing your problems.
     

Share This Page