strange behavior of postfix/dovecot/

Discussion in 'Installation/Configuration' started by pine1455, Feb 3, 2008.

  1. pine1455

    pine1455 New Member

    Hi,
    I followed all instructions described in http://www.howtoforge.com/centos-5.1...p-ispconfig-p1
    I put some changes to have [email protected] athu for SMTP ... Every things seem to be OK ... but the little problem .. when I set auth for my mail client It force me to provide correct user/pass but I found that it Also works without athu !!! Does anybody know how I can force my postfix/dovecot to athu all users to use SMPT server?!!!

    TNX
    --Pine

    ==== /etc/postfix/main.cf ==========
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    broken_sasl_auth_clients = yes
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    debugger_command =
    debug_peer_level = 2
    home_mailbox = Maildir/
    html_directory = no
    inet_interfaces = all
    mailbox_command =
    mail_owner = postfix
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydestination = /etc/postfix/local-host-names
    myhostname = www.mydomain.com
    mynetworks = 127.0.0.0/8
    newaliases_path = /usr/bin/newaliases.postfix
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    smtpd_banner = $host Mail Server
    smtpd_recipient_restrictions = ermit_sasl_authenticated,permit_mynetworks,reject_ unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain = $mydomain
    smtpd_sasl_path = private/auth
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_type=dovecot
    smtpd_tls_auth_only = no
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    smtpd_use_tls = yes
    smtp_sasl_auth_enable = no
    smtp_tls_note_starttls_offer = yes
    smtp_use_tls = yes
    tls_random_source = dev:/dev/urandom
    unknown_local_recipient_reject_code = 450
    unknown_local_recipient_reject_code = 550
    virtual_maps = hash:/etc/postfix/virtusertable
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    =========== /etc/dovecot.conf ==========

    protocols = imap imaps pop3 pop3s
    protocol imap {
    }
    protocol pop3 {
    }
    protocol lda {
    postmaster_address = [email protected]
    hostname = www.mydomain.com
    }
    auth_username_format ="%Ld_%Ln"
    auth_debug = yes
    auth default {
    mechanisms = plain login
    passdb pam {
    }
    userdb passwd {
    }
    user = root
    socket listen {
    client {
    path = /var/spool/postfix/private/auth
    mode = 0660
    user = postfix
    group = postfix
    }
    }
    }
    dict {
    }
    plugin {
    }
    =================
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
     
  3. pine1455

    pine1455 New Member

    I have no error ... my problem is that client can send mail via one of the following method :
    1. no smtp authentication ... !!!!
    2. correct smtp authentication

    my server work with/without smtp authentication I want to force them to authentication themselves t my server ...

    TNX

    --Pine
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You have a typo in your main.cf:
    It must be
    Code:
    smtpd_recipient_restrictions = [B][COLOR="Red"]p[/COLOR][/B]ermit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    instead.
     
  5. pine1455

    pine1455 New Member

    It was my mistake in copy/past ;) .. my postfix has a correct settings ... :confused: I'm getting cunfused ...
     
    Last edited: Feb 6, 2008
  6. pine1455

    pine1455 New Member

    I found the problem.... It was working OK.... It smtp need auth to send mail to other SMTP server .. it deliver all local mail without auth ...

    TNX
    Pine
     

Share This Page