Strange behavior in a cluster of two web servers

Discussion in 'Installation/Configuration' started by baptistebrus, Jul 12, 2018.

  1. baptistebrus

    baptistebrus New Member

    Hello,
    Since few month, we had a cluster of ISPConfig like that:
    • old-server: all services and web interface
    • ha1: web server
    • ha2: web server
    Everything was working well, but I have a strange problem with one website.
    This site is the web221 and the client is the client20.
    ls -al on ha1:
    [​IMG]
    ls -al on ha2:
    [​IMG]
    And another strange thing, on ha2, logs go into "log" folder without problem, but it's not working on ha1.
    I have check "Apply permission on site update" and i update the website, without any results.
    Have you got an idea?
    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have the 'connect userid to web id' option under system > server config > web enabled for both servers?
     
  3. baptistebrus

    baptistebrus New Member

    No, i must try ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This option is a requirement to run a cluster, see ISPConfig cluster tutorials. The problem is when you set it now, then this can not heal your current setup as this settings must be set right from the beginning and I'm not really sure what will happen when you enable it now. But this option should take acre on the numeric UID of a site and not the name of the web user, so there is probably something else wrong too on your server, maybe a mistake at the time it was converted from single server to cluster. My guess is that you have a different number of sites in the web_domain table on the tow servers.
     
  5. baptistebrus

    baptistebrus New Member

    I already check theses table:
    web_domain table on ha1
    [​IMG]
    web_domain table on ha2
    [​IMG]
    Everything seems fine, I can schedule to apply this checkbox if you think it's can be useful.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please compare the /etc/passwd files of the servers, check if the numeric UID's of the users match.
     
  7. baptistebrus

    baptistebrus New Member

    I found the problem
    ha1
    [​IMG]
    ha2
    [​IMG]
    How can i fix that ?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to correct that in the passwd file, ispconfig itself does not store the numeric ID's of the users in it's database. Then you should check if the website file and folder ownership of that site is ok again.
     
  9. baptistebrus

    baptistebrus New Member

    I tested the modification during off-peak hours, the result is positive. It's working perfectly.
    Thanks for your help
     
  10. baptistebrus

    baptistebrus New Member

    But this problem has not been resolved:
     
  11. Jesse Norell

    Jesse Norell Well-Known Member

    Check the pathnames for the bind mounts in /etc/fstab, you could have the same name mix-up.
     
  12. baptistebrus

    baptistebrus New Member

    Yes indeed.
    Now I wouldn't have any more problems because I check "connect userid to web id" ?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem that UID's on the two servers should not reoccur when this option is enabled as it forces both systems to use the same UID by using the actual web ID as basis.
     
  14. baptistebrus

    baptistebrus New Member

    Ok, thanks for your help.
    Have a nice day
     

Share This Page