Stops all spam regardless of settings?

Discussion in 'Installation/Configuration' started by Nicke, Feb 9, 2010.

  1. Nicke

    Nicke New Member

    Hi!

    I changed "Spamfilter" to "- Not enabled -" for both the domain and my private e-mailadress. After that i tried to send myself a spam message.

    The server does still mark the mail as spam and does not deliver the message to my mailbox. I suspect that the server has done this always. I have never gotten a email marked with "***SPAM***"....

    Whats wrong?

    Edit:
    I did go to Spamfilter - User/Domain and removed my user there.. it removed my mail account! Its gone! :-S
    Lost some ~500 emails... is this the way it should work?

    Edit2:
    I think i got the spam-thing working..

    Please tell me some good settings for the normal policy. :)

    SPAM tag level
    SPAM tag2 level
    SPAM kill level
    SPAM dsn cutoff level
    SPAM quarantine cutoff level
    SPAM modifies subject
    SPAM subject tag
    SPAM subject tag2
     
    Last edited: Feb 9, 2010
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No, this will not delete your emails. Just checked the sources, its impossible. You must ahve clicked on the delete button of the mailboxes and not on the mail filters. Verified this just on my mailserver and my mailbox did not got deleted.


    SPAM tag level 2
    SPAM tag2 level 3.501
    SPAM kill level 15
    SPAM dsn cutoff level
    SPAM quarantine cutoff level
    SPAM modifies subject yes
    SPAM subject tag ***SPAM***
    SPAM subject tag2
     
  3. Nicke

    Nicke New Member

    I was suspecting that myself.. i must have gone to the wrong place the second time... deleted my personal e-mailadress from the right place at first and then the whole domain after that from the wrong place.. :(
     
    Last edited: Feb 10, 2010
  4. Nicke

    Nicke New Member

    Yes, score=4.689 tagged_above=2 required=3.501
    tests=[BAD_ENC_HEADER=2.87, MIME_QP_LONG_LINE=1.819] autolearn=no

    Should autolearn be off?
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, as the score is too low for autolearning. Otherwise the filter might learn wrong emails. If the score is highre, the mail will get learned as spam. This works all very well and fully automatic, so you dont have to care about that.
     
  6. Nicke

    Nicke New Member

    Thank you!

    How does the Whitelist work?
    If I want to add a filter for all users in a domain i select @domain.com in the drop down list and then i add my filter.. like *@domain2.com?
    No need to add to the whitelist for each user?
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  8. Nicke

    Nicke New Member

    Thanks. I will.

    How do i add the score to the subject.. like ***SPAM (Score: 3.5)***?
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The score is added in the mail header and not the subject.
     
  10. Nicke

    Nicke New Member

    But i should be able to add it myself? I found it somewhere in the forum but i cant find the thread again...
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I'am not aware of such an option. But you may read the amavisd doku for details.
     
  12. Nicke

    Nicke New Member

    This worked:
    *** SPAM (_SCORE_) ***

    :)
     

Share This Page