stopped recieving mails - all mails are NOQUEUE

Discussion in 'ISPConfig 3 Priority Support' started by muelli75, Feb 6, 2021.

  1. muelli75

    muelli75 Member HowtoForge Supporter

    Debian Buster, ISPConfig 3.2.2
    some domains are hosted, all was working well. Until tomorrow, now there is no mail accepted. Alle mails are NOQUEed.
    No updates were installed tomorrow, no changes were done.

    mail.log
    Code:
    Feb  6 14:46:41 monarch dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=23535, secured, session=<0BSjKqu6WIt/AAAB>
    Feb  6 14:46:41 monarch dovecot: imap([email protected])<23535><0BSjKqu6WIt/AAAB>: Logged out in=50 out=556 deleted=0 expunged=0 trashed=0 hdr_count=0 hdr_bytes=0 body_count=0 body_bytes=0
    Feb  6 14:47:41 monarch dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=23615, secured, session=<RHk4Lqu6iIt/AAAB>
    Feb  6 14:47:41 monarch dovecot: imap([email protected])<23615><RHk4Lqu6iIt/AAAB>: Logged out in=50 out=556 deleted=0 expunged=0 trashed=0 hdr_count=0 hdr_bytes=0 body_count=0 body_bytes=0
    Feb  6 14:48:41 monarch dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=23728, secured, session=<LfPNMau63It/AAAB>
    Feb  6 14:48:41 monarch dovecot: imap([email protected])<23728><LfPNMau63It/AAAB>: Logged out in=50 out=556 deleted=0 expunged=0 trashed=0 hdr_count=0 hdr_bytes=0 body_count=0 body_bytes=0
    Feb  6 14:49:07 monarch postfix/smtpd[21900]: NOQUEUE: filter: RCPT from mail.senderdomain.at[46.4.28.16]: <officefromsender.at>: Sender address triggers FILTER lmtp:[127.0.0.1]:10026; from=<officefromsender.at> to=<[email protected]> proto=ESMTP helo=<mail.senderdomain.at>
    Feb  6 14:49:07 monarch postfix/smtpd[21900]: NOQUEUE: filter: RCPT from mail.senderdomain.at[46.4.28.16]: <officefromsender.at>: Sender address triggers FILTER lmtp:[127.0.0.1]:10024; from=<officefromsender.at> to=<[email protected]> proto=ESMTP helo=<mail.senderdomain.at>
    Feb  6 14:49:07 monarch postfix/smtpd[21900]: NOQUEUE: reject: RCPT from mail.senderdomain.at[46.4.28.16]: 450 4.1.1 <[email protected]>: Recipient address rejected: unverified address: host monarch.products4more.at[private/dovecot-lmtp] said: 501 5.5.4 Invalid FROM: Invalid domain (in reply to MAIL FROM command); from=<officefromsender.at> to=<[email protected]> proto=ESMTP helo=<mail.senderdomain.at>
    Feb  6 14:49:07 monarch postfix/lmtp[23269]: 6EC36558E368: to=<[email protected]>, relay=monarch.products4more.at[private/dovecot-lmtp], delay=0.05, delays=0.05/0/0/0, dsn=5.5.4, status=undeliverable (host monarch.products4more.at[private/dovecot-lmtp] said: 501 5.5.4 Invalid FROM: Invalid domain (in reply to MAIL FROM command))
    Hm, checked syslog - there are often lines like
    Code:
    Feb  6 00:15:41 servername named[13325]: client @0x7ff89c1a10b0 47.225.180.104#5845 (.): query (cache) './ANY/IN' denied
    Feb  6 00:15:41 servername named[13325]: client @0x7ff89c1cc760 47.225.180.104#5845 (.): query (cache) './ANY/IN' denied
    Feb  6 00:15:41 servername named[13325]: client @0x7ff89c192920 47.225.180.104#5845 (.): query (cache) './ANY/IN' denied
    Feb  6 00:15:41 servername named[13325]: client @0x7ff89c1af840 47.225.180.104#5845 (.): query (cache) './ANY/IN' denied
    On this host, there is no bind.

    Any ideas how to deliver mails again?

    Thank you!
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    So you can not send out mails, or you can not receive? or both?

    Is this only with one external mailserver or all?
     
  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Postfix rejected because it couldn't verify the sender via lmtp; dovecot-lmtp replied that it is an invalid domain in the sender address.

    Not sure what's going on the, but restart mail services if you have not. Then I would re-enter your email address in your mail client, maybe it got some non-printable character in there? Or try sending with another client, eg. roundcube.
     
  4. muelli75

    muelli75 Member HowtoForge Supporter

    @Th0m sending is possible, to any domain.
    recieving is not possibie, no domain on this server can recieve mails.
    @Jesse Norell no mailbox is recivieving mails. every mail to an existing or nonexisting is noqueued.

    In the meantime I restarted the mailservice (postfix) several times and the machine once.
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share the real domains in the log?
     
  6. muelli75

    muelli75 Member HowtoForge Supporter

    Actual mail.log
    Code:
    Feb  6 17:59:01 monarch postfix/smtpd[18423]: connect from tesoro.products4more.at[46.4.28.16]
    Feb  6 17:59:01 monarch postfix/smtpd[18423]: NOQUEUE: filter: RCPT from tesoro.products4more.at[46.4.28.16]: <[email protected]>: Sender address triggers FILTER lmtp:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<tesoro.products4more.at>
    Feb  6 17:59:01 monarch postfix/smtpd[18423]: NOQUEUE: filter: RCPT from tesoro.products4more.at[46.4.28.16]: <[email protected]>: Sender address triggers FILTER lmtp:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<tesoro.products4more.at>
    Feb  6 17:59:01 monarch postfix/cleanup[18977]: 686CD558E9F9: message-id=<[email protected]>
    Feb  6 17:59:01 monarch postfix/smtpd[18423]: NOQUEUE: reject: RCPT from tesoro.products4more.at[46.4.28.16]: 450 4.1.1 <[email protected]>: Recipient address rejected: unverified address: host monarch.products4more.at[private/dovecot-lmtp] said: 501 5.5.4 Invalid FROM: Invalid domain (in reply to MAIL FROM command); from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<tesoro.products4more.at>
    Feb  6 17:59:01 monarch postfix/smtpd[18423]: disconnect from tesoro.products4more.at[46.4.28.16] ehlo=2 starttls=1 mail=1 rcpt=0/1 data=0/1 rset=1 quit=1 commands=6/8
    Checked mail.err
    Code:
    Feb  6 12:54:19 monarch dovecot: auth-worker(1249): Error: mysql(localhost): Connect failed to database (dbispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) - waiting for 5 seconds before retry
    Feb  6 12:54:24 monarch dovecot: auth-worker(1249): Error: mysql(localhost): Connect failed to database (dbispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) - waiting for 25 seconds before retry
    Feb  6 12:54:24 monarch dovecot: auth-worker(1249): Error: mysql(localhost): Connect failed to database (dbispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) - waiting for 25 seconds before retry
    
    Since the restart of the server there is no error.

    Mariadb is up and running

    If I restart postfix, mail.log says:
    Code:
    Feb  6 18:03:38 monarch postfix/postfix-script[20615]: stopping the Postfix mail system
    Feb  6 18:03:38 monarch postfix/master[18323]: terminating on signal 15
    Feb  6 18:03:38 monarch postfix/postfix-script[20735]: warning: group or other writable: /etc/postfix/./smtpd.key-20201117204629.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20736]: warning: group or other writable: /etc/postfix/./smtpd.cert-20201117204629.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20741]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert
    Feb  6 18:03:38 monarch postfix/postfix-script[20744]: warning: symlink leaves directory: /etc/postfix/./smtpd.key.old
    Feb  6 18:03:38 monarch postfix/postfix-script[20747]: warning: symlink leaves directory: /etc/postfix/./smtpd.key-20201117204629.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20750]: warning: symlink leaves directory: /etc/postfix/./smtpd.key
    Feb  6 18:03:38 monarch postfix/postfix-script[20753]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert-20201117204629.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20756]: warning: symlink leaves directory: /etc/postfix/./smtpd.key.old2
    Feb  6 18:03:38 monarch postfix/postfix-script[20759]: warning: symlink leaves directory: /etc/postfix/./smtpd.key-20201118074642.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20762]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20765]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert-20201118075302.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20768]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert.old2
    Feb  6 18:03:38 monarch postfix/postfix-script[20771]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert-20201118074642.bak
    Feb  6 18:03:38 monarch postfix/postfix-script[20774]: warning: symlink leaves directory: /etc/postfix/./smtpd.key-20201118075302.bak
    Feb  6 18:03:39 monarch postfix/postfix-script[20777]: warning: symlink leaves directory: /etc/postfix/./makedefs.out
    Feb  6 18:03:39 monarch postfix/postfix-script[20780]: warning: symlink leaves directory: /etc/postfix/./smtpd.cert.old
    Feb  6 18:03:39 monarch postfix/postfix-script[20821]: starting the Postfix mail system
    Feb  6 18:03:39 monarch postfix/master[20823]: daemon started -- version 3.4.14, configuration /etc/postfix
    Feb  6 18:03:42 monarch postfix/smtps/smtpd[20832]: warning: hostname net6-ip210.linkbg.com does not resolve to address 87.246.7.210: Name or service not known
    Feb  6 18:03:42 monarch postfix/smtps/smtpd[20832]: connect from unknown[87.246.7.210]
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    So it's working now? Or you now have a new issue related to dns?
     
  8. muelli75

    muelli75 Member HowtoForge Supporter

    Its not working - I dont know if this issue is related to dns. I think its related to certifcates.
     
  9. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You can ignore the symlink warmings. What are your new symptoms and log messages from when it happens?
     
  10. muelli75

    muelli75 Member HowtoForge Supporter

    All the same as before, see logs from post #6 in this thread.
    excerpt
     
  11. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No mysql errors now?
     
  12. muelli75

    muelli75 Member HowtoForge Supporter

    in /var/log/mysql/error.log there are such lines

    Code:
    2021-02-07  6:53:48 110672 [Warning] Aborted connection 110672 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07  6:55:29 110813 [Warning] Aborted connection 110813 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07  7:45:23 115037 [Warning] Aborted connection 115037 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07  8:59:45 122147 [Warning] Aborted connection 122147 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07  9:03:28 122478 [Warning] Aborted connection 122478 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07  9:38:32 127832 [Warning] IP address '185.167.97.31' could not be resolved: Name or service not known
    2021-02-07 10:54:44 134766 [Warning] Aborted connection 134766 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07 11:04:43 135599 [Warning] Aborted connection 135599 to db: 'dbispconfig' user: 'ispconfig' host: 'localhost' (Got an error reading communication packets)
    2021-02-07 11:15:41 136683 [Warning] IP address '139.198.19.70' could not be resolved: Name or service not known
     
  13. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Try doing a forced update of ISPConfig and reconfigure services:
    Code:
    ispconfig_update.sh --force
    If you still experience issues, search on the forum/online for the MySQL errors you saw.

    You can do a send/receive test with https://ismyemailworking.com/
     
  14. muelli75

    muelli75 Member HowtoForge Supporter

    I did the reconfiguration, but with no effect.

    mail.err
    Code:
    Feb  7 22:08:37 monarch dovecot: auth-worker(18580): Error: mysql(localhost): Connect failed to database (dbispconfig): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) - waiting for 5 seconds before retry
    https://ismyemailworking.com/ is not working today - "Our apologies but we are experiencing technical difficulties at the moment. Please try again later."

    hm, any further ideas? TIA
     
  15. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Hmm, I had a problem like this earlier. Are you using incrontab? What is shown in
    Code:
    incrontab -e
     

Share This Page