Still unsure about subdomains...

Discussion in 'Installation/Configuration' started by HMK, May 17, 2007.

  1. HMK

    HMK New Member

    (Apologies for posting in the wrong forum initially...)

    --------------


    Hi; I have a domain (abc.com). I use my registrar's nameservers (I cannot change this), and have created A records for my domain:

    Nameservers:
    ns1.ozregistrar.com
    ns2.ozregistrar.com

    A record:
    www.abc.com --> 202.111.222.333 (my server)

    In ISPConfig, everything works fine for my domain: when I type www.abc.com into my browser, I get straight to my home page.

    --------------
    HOWEVER, I need to create independent subdomains (with associated email addresses) that point as follows:

    www.123.abc.com --> http://www.google.com
    www.456.abc.com --> http://www.yahoo.com

    AND

    someone@123.abc.com --> john.citizen@aol.com
    whoever@456.abc.com --> mary.citizen@harvard.edu

    --------------

    I have checked the forums, and tried to follow instructions, but I have had no success. Can someone help me out, please? I would be grateful for *explicit* instructions.

    I would like to create the subdomains on ISPConfig (not with my registrar).

    Thankyou for your help.
    HMK
    Australia.
     
  2. till

    till Super Moderator

    Hi,

    just create websites for the other domains and add e.g. a script or html page with a header redirect as index document. Then create the email accounts for the websites and redirect the emails.
     
  3. HMK

    HMK New Member

    Thankyou...but still no success

    Thankyou, Till.

    But it is the creation of the other (sub)domains that is causing the initial problem.

    I have tried both of the following scenarios without success:

    ----------------------

    1.
    Server: MyServer
    Hostname: 123
    Domain: abc.com
    IP Address: 192.68...
    Create DNS: Unchecked
    Create DNS-MX: Unchecked

    (Co-domains: empty)

    2.
    Server: MyServer
    Hostname: www
    Domain: 123.abc.com
    IP Address: 192.68...
    Create DNS: Checked
    Create DNS-MX: Unchecked

    (Co-domains: empty)

    ----------------------

    What am I doing wrong? It is creating the actual subdomains (www.123.abc.com, etc.) in the first place that is causing the problem.

    Thankyou
    HMK.
     
  4. torusturtle

    torusturtle ISPConfig Developer

    Hi

    since you don't need an email somebody@www.123.abc.com you don't have to create a new domain for www.123.abc.com

    You'll have to do the following:

    1. Create new domain

    Server: MyServer
    Hostname: 123
    Domain: abc.com
    IP Address: 192.68...
    Create DNS: checked
    Create DNS-MX: checked

    2. create emails in this domain
    Set the forward role for each email in the Advanced Settings
    e.g. someone@somwhere.com

    3. create codomain
    Hostname: www
    Domain: 123.abc.com
    Create DNS: checked
    Create DNS-MX: unchecked
    Forward: http://www.forwardURL.com

    That should do it.

    I have an Asterisk rule for my main domain e.g. *.domain.tld CNAME domain.tld which allows me to create as many subdomains as I want without creating new DNS entries all the time.
     
  5. HMK

    HMK New Member

    Thankyou very much

    Thankyou very much, torusturtle.

    I will try what you suggested and will report back in due time. (I might contact you again about your asterisk rule, too.)

    I do appreciate your clear instructions...thankyou again.

    HMK
    Australia.
     
  6. torusturtle

    torusturtle ISPConfig Developer

    Hi HMK

    I'm happy to help!
    It's my contribution to this great product and I know how it is to have a unsolved problem. :)
     
  7. HMK

    HMK New Member

    Alas, still not working...

    I created a new subdomain (test1.abc.com) 36 hours ago using the instructions above, but unfortunately it is still not working:

    "Internet explorer cannot display the webpage."
    "Ping request cannot find host test1.abc.com"

    (No success with email either, of course, nor with the subdomain www.test1.abc.com.)

    The parent domain (www.abc.com) continues to work as normal. (This came online just a couple of hours after being created.)

    Refreshing the browser makes no difference.

    Should I continue to wait? Or try something else?

    Thankyou.
     
  8. till

    till Super Moderator

    Please check the domain that you craeted at your registrar. As ping is not configured by ISPConfig, it should work even if you configured ISPConfig wrong, so the problem must be that the DNS A-Record for test1.abc.com is not creted correctly at your registrars DNS server.
     
  9. HMK

    HMK New Member

    Thankyou so much, Till and torusturtle.

    The problem was at my registrar, as you indicated. I did not realise that I had to create separate A records for each subdomain, but in the end I used an asterisk rule, and everything is working perfectly.

    I am very grateful to you both. Thankyou for taking the time to reply; it is thrilling to see everything working as it should.

    HMK
    Melbourne, Australia
     

Share This Page