Still have problems with DNS

Discussion in 'Installation/Configuration' started by nissy, Sep 3, 2010.

  1. nissy

    nissy New Member

    Hi people, hope you can help with this one!

    I created a co-host x for my existing domain, I ticked so it would create the correspondent DNS record. If I go to the DNS section, I see the A entry, but if I dig/nslookup my server, it says no A entry was created.

    Also, I have many problems with DNS server, when I dig/noslookup it only shows information on the root domain and NS, doesn't show all the A records, doesn't show any CNAME information, and also when I create new CNAME records using the web interface on ispconfig, it normally doesn't work.

    I've tried both using co-host option and creating dns manually...

    Any ideas?

    Thanks

    Nissy
     
  2. falko

    falko Super Moderator

    Is your ISPConfig server the authoritative nameserver for your domain? You can check that by running
    Code:
    dig ns yourdomain.com
    Also, you can check your DNS settings on www.intodns.com
     
  3. nissy

    nissy New Member

    Yes, they are authorizative and in intodns.com everything shows ok...
    If you dig or nslookup it also shows ok...

    If you try to dig the subdomain x (x.domain.com) it says no record is found. If I go to the zone pri.domain.com the record is indeed created.

    How can you make so that the changes made to a zone reflect into the cache zone? (I mean that pri.domain.com and pri.domain.com~ have the same entries).

    For what I see, pri.domain.com~ is the one the system uses, right?

    Thanks

    Nissy
     
  4. falko

    falko Super Moderator

    No, pri.domain.com~ is just a backup of the zone file from before the latest changes. It is not being used by named.
     
  5. nissy

    nissy New Member

    Thanks for your reply, but that doesn't solve the fact that my server still doesn't answer to the records stated in the zone file...
     
  6. falko

    falko Super Moderator

    Can you post your zone file and your named.conf?
     
  7. createch

    createch ISPConfig Developer

    can you check in your ISPConfig panel ....

    a) whether named.conf is set as:
    /var/named/chroot/etc/named.conf

    and

    b) whether zonefiles dir is set as
    /var/named/chroot/var/named
     
  8. nissy

    nissy New Member

    Hi,

    I have checked and in ISPConfig the file named.conf points to:
    /etc/bind/named.conf

    when I look in the system, I have 2 named.conf:
    /etc/bind/named.conf
    /var/lib/named/etc/bind/named.conf
    both with the same content, same thing for the zones, ispconfig it's set as follows:

    /etc/bind
    but when I look at the zones, they are also copied in:
    /var/lib/named/etc/bind
    also with the same contents, and the contents reflect what is set on ispconfig panels.

    I am attaching named.conf and the zone. The failing dns entry is "zencart", it simply doesn't answer when you dig or nslookup it.

    to createch: the path /var/named/chroot/ doesn't even exist. I am running a ubuntu 8.10, installation using the perfect server guide for it.

    BTW, in another domain I created a co-host webmail pointing to an http address, it worked in another domain, but with this one it doesn't, don't know why, guess it's related all to the same...

    Thanks for your help, I have no idea how to fix this...

    Nissy
     

    Attached Files:

  9. falko

    falko Super Moderator

  10. nissy

    nissy New Member

    Hi again,

    Changed it so it has glue records for both ns01 and ns02, and changed the cname entries to A entries, this was like 3 hours ago. Now if I dig/nslookup using the IP associated to the server, and ask for the A record for zencart.formacion-tecnica.com, which is in the zone, it still says it doesn't exist (¿?)

    Anyway, for another domain happens the same, I created a "webmail" A record and if you dig it directly to the IP on the server, it says record is non-existant, and the record does appear in the zone file...

    I have also used dig/nslookup setting server to localhost, and it also says that records DO NOT EXIST (wtf?)

    Any ideas??

    Thnks - Nissy
     
  11. nissy

    nissy New Member

    Just so you know, I solved the issue!

    For some reason named was not correctly running, it was running by root user and not in the usual style... I forced kill in the open processes and launched command "/usr/sbin/named -u bind -t /var/lib/named" and after that it started working again :)

    Do yo have any documentation on how has to run bind in a ispconfig server?

    Thanks anyway

    Nissy
     
  12. till

    till Super Moderator

Share This Page