Still errors with Openssl on Etch

Discussion in 'Installation/Configuration' started by jake, May 27, 2007.

  1. jake

    jake New Member

    Hello,

    First off, thank you for a great piece of software. I've been using ISPConfig for 6 months now, and I found a very easy to use! A great tool.

    Recently i've tried to upgrade the installation to the latest version but there something went wrong. So i decided to reinstall my (virtual server). But whatever i try the install seems to go wrong everytime.

    I've tried to change the line in compile_aps/compile as described in one of the other topics, but when i do that, i'm able to go to certifcate generation. But this generation takes forever. I've let it run for 24 hours, but it was still busy.
    If i don't change the lines i've got the following error:

    Here's some info from my system:
    Code:
    uname -a
    Linux broomhilda.hyperactief.com 2.6.17.13-vs2.0.2.1-node-b02 #1 SMP Thu May 17 22:00:00 UTC 2007 x86_64 GNU/Linux
    Running debian etch 4.0

    I followed the perfect setup as closely as possible (due to having a vserver). I skipped the quota section partially and was unable to install bind9 (has been replaced by dnsutils?) so i installed bind. Perhaps a problem with the sources.list file?

    The error:
    Code:
    gcc -DMONOLITH -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DMD32_REG_T=int -DMD5_ASM   -c -o s_server.o s_server.c
    /tmp/ccI8c8VC.s: Assembler messages:
    /tmp/ccI8c8VC.s:437: Error: Incorrect register `%rax' used with `l' suffix
    /tmp/ccI8c8VC.s:445: Error: Incorrect register `%rbx' used with `l' suffix
    /tmp/ccI8c8VC.s:465: Error: Incorrect register `%rdx' used with `l' suffix
    /tmp/ccI8c8VC.s:466: Error: Incorrect register `%rbx' used with `l' suffix
    make[1]: *** [s_server.o] Error 1
    make[1]: Leaving directory `/root/install_ispconfig/compile_aps/openssl-0.9.8e/apps'
    make: *** [build_apps] Error 1
    ERROR: Could not make OpenSSL
    rm: cannot remove `install_ispconfig/.nfs00000000025447870006afb9': Device or resource busy
    rm: cannot remove `install_ispconfig/.nfs00000000025448550006afba': Device or resource busy
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    
    Any help is greatly appreciated, thank you!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you follow exactly the perefct setup guide for debian etch?
     
  3. jake

    jake New Member

    Hi,

    Thanks for your reply. I followed the setup guide as closely as possible. Because i'm on a vserver i was unable to implement quota (though i installed the package). Furthermore i was unable to install bind9 but installed bind instead.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure what's causing the error, but I think it's related to you using a vserver. Sometimes they don't behave like dedicated servers. :(
     
  5. jake

    jake New Member

    Hmm, that's too bad because the previous install had no such problems. Do you know what may be causing the generating of the certificate too take so long when i change the lines in compile_aps/compile?
    If i can solve that i guess everything should be working as it should.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    What exactly did you change in the compile_aps/compile script?
     
  7. jake

    jake New Member

  8. jnsc

    jnsc rotaredoM Moderator

    I had something very similar on a Vserver. A uname -a was telling it was a x86_64 but the vserver was installed as a i386. This was causing SSL compilations errors.
     
  9. jake

    jake New Member

    What did you do to solve it?
    If i just knew what the certifcate generation is taking so long it might help.
     
  10. jnsc

    jnsc rotaredoM Moderator

    It was a Vserver from vserver.de, after a reboot a uname -a showed the right value i386 instead of x86_64
     
  11. jake

    jake New Member

    My ISP has upgraded the kernel, so now it seems setup is running better. It continues past the SSL compilation and certficate generation but after the php compilation i get the next error:

    Code:
    Build complete.
    Don't forget to run 'make test'.
    
    Installing PHP SAPI module:       apache
    [activating module `php5' in /root/ispconfig/httpd/conf/httpd.conf]
    cp libs/libphp5.so /root/ispconfig/httpd/libexec/libphp5.so
    chmod 755 /root/ispconfig/httpd/libexec/libphp5.so
    cp /root/ispconfig/httpd/conf/httpd.conf /root/ispconfig/httpd/conf/httpd.conf.bak
    cp /root/ispconfig/httpd/conf/httpd.conf.new /root/ispconfig/httpd/conf/httpd.conf
    rm /root/ispconfig/httpd/conf/httpd.conf.new
    Installing PHP CLI binary:        /root/ispconfig/php/bin/
    Installing PHP CLI man page:      /root/ispconfig/php/man/man1/
    Installing build environment:     /root/ispconfig/php/lib/php/build/
    Installing header files:          /root/ispconfig/php/include/php/
    Installing helper programs:       /root/ispconfig/php/bin/
      program: phpize
      program: php-config
    Installing man pages:             /root/ispconfig/php/man/man1/
      page: phpize.1
      page: php-config.1
    Installing PDO headers:          /root/ispconfig/php/include/php/ext/pdo/
    tar: ispconfig_tmp/httpd/htdocs/index.html.ru.cp866: file changed as we read it
    tar: ispconfig_tmp/httpd/htdocs/index.html.ru.iso-ru: file changed as we read it
    tar: ispconfig_tmp/httpd/htdocs/index.html.hu: file changed as we read it
    tar: ispconfig_tmp/httpd/htdocs/index.html.ru.cp-1251: file changed as we read it
    
    ......
    
    tar: ispconfig_tmp/httpd/icons/folder.open.gif: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/generic.red.gif: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/apache_pb.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/left.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/alert.black.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/pie1.gif: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/burst.gif: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/screw1.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/text.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/world2.gif: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/pie2.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/movie.png: file changed as we read it
    tar: ispconfig_tmp/httpd/icons/index.png: file changed as we read it
    ERROR: Could not create aps.tar.gz
    rm: cannot remove `install_ispconfig/.nfs02584ccb000f1b60': Device or resource busy
    rm: cannot remove `install_ispconfig/.nfs02584d9e000f1b61': Device or resource busy
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    
    Anyone who can help me?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have enough space on your harddisk? Please post the output of:

    df -h

    from which folder did you try to install ISPConfig?
     
  13. jake

    jake New Member

    Hi, thnx for your quick reply!

    I still have 9 gig free:
    Code:
    broomhilda:/home# df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/hdv1             9.8G  831M  9.0G   9% /
    
    Furthermore i'm installing from the root folder. Of course with root priviliges. I will try to install from /tmp now.
     
  14. jake

    jake New Member

    No luck...
     
  15. falko

    falko Super Moderator ISPConfig Developer

    What's the error you get when you try to install from the /tmp directory?
     
  16. jake

    jake New Member

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that tar is not able to create a tar.gz file because the files change while they where added. Maybe its a problem in your /tmp directory with some type of cleanup script or similar.

    Please try to unpack the ISPConfig installer in e.g. /usr/src/, then run:

    cd install_ispconfig
    ./setup
     
  18. jake

    jake New Member

    Hi,

    I've reinstalled the vserver with debian 3.1. Once again the server setup seems te be progressing a bit more. However it still exited with an error. I believe there is something wrong with clamav or spamassisn.
    Could be please help?

    Thanks!
     

    Attached Files:

  19. jnsc

    jnsc rotaredoM Moderator

    you are missing 2 required SpamAssassin module:
    Code:
    REQUIRED module missing: Digest::SHA1
    REQUIRED module missing: Net::DNS
    
    Did you follow the Perfect Setup guide? Especially the part "Install some Perl Modules needed by SpamAssassin" on page 5?
     
  20. jake

    jake New Member

    Got it, found the error on the forum!

    Thank you for your help, everything is working now!

    Great Job!
     

Share This Page