Stats Not working...sorry if posted before.

Discussion in 'Installation/Configuration' started by domh, Oct 8, 2008.

  1. domh

    domh New Member

    Hi All,

    I have what seems to be a common problem. I have an ISPconfig server that has been running for about 4 months. When I started the stats worked fine, now I get the error 403 Error- Forbidden! when trying to log into

    Also there are no traffic stats under statistics tabs under each website inside ISPCONFIG.

    Also the /var/www/web1/web/stats folder is empty (apart from a .htaccess file that lists my users)

    I say that this is a common problem because I have seen a lot of threads stating the problem however a lot of people have fixed it by rebuilding the server from scratch.

    I tried unchecking then rechecking webalizer, that did not help. I tried stopping CRON then opening crontab -e and resaving then restarting CRON. That did not help.

    I look forward to your help.

  2. falko

    falko Super Moderator ISPConfig Developer

    Did you make any changes to the system right before the problem started? Maybe an update or anything else?
  3. domh

    domh New Member

    I did an apt-get update and apt-get apgrade (or the other way around) before it. Could that be it?

    Thanks for your help.

  4. falko

    falko Super Moderator ISPConfig Developer

    If that's the only thing that has changed, then that's probably the problem. Which distribution are you using? What are the outputs of
    which webalizer
    crontab -l
  5. domh

    domh New Member

    Hi there,

    I am using Ubuntu Server 8.04.1 built with the perfect server script.

    [email protected]:/var/www/web1/user/web1_cath# which webalizer

    [email protected]:/var/www/web1/user/web1_cath# crontab -l
    30 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/ftp_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/mail_logs.php &> /dev/null
    59 23 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/cleanup.php &> /dev/null
    0 4 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php &> /dev/null
    0,30 * * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php &> /dev/null
    15 3,15 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/quota_msg.php &> /dev/null
    40 00 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/traffic.php &> /dev/null
    05 02 * * * /root/ispconfig/php/php /root/ispconfig/scripts/shell/backup.php &> /dev/null
    [email protected]:/var/www/web1/user/web1_cath#
  6. lyndros

    lyndros New Member

    You can try to run manually the script and seeing what's happening

    $/root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php

  7. falko

    falko Super Moderator ISPConfig Developer

    Yes, but please run the command as root.

Share This Page