stats not updating anymore

Discussion in 'Installation/Configuration' started by dwalin, Sep 27, 2013.

  1. dwalin

    dwalin New Member

    Hi,

    I had to move my installation from one server to another (hardware failure). So far it seems to work fine, except the stats. It does not matter if webalizer or awstat, but both are not updated anymore.

    I have looked at the permissions of /var/www/clients/clientX/webX/web/stats/ and changed them back to root:root but that did not solve the problem.

    The scripts /usr/local/ispconfig/server/server.sh and /usr/local/ispconfig/server/cron_daily.php do not report any errors if I run them manual.

    Has anyone an idea, where to look? Do you need some more information?

    [EDIT]Forgot to tell: System is Cento OS 6.4 and the ispconfig version is 3.0.5.3[/EDIT]

    Thanks in advance!
     
    Last edited: Sep 27, 2013
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do the website log files contain recent entries?
     
  3. dwalin

    dwalin New Member

    yes,

    they are updated and also every day is a new log file present:

    -rw-r--r-- 1 root root 969563 24. Sep 23:59 20130924-access.log
    -rw-r--r-- 1 root root 1012361 25. Sep 23:59 20130925-access.log
    -rw-r--r-- 1 root root 1059999 26. Sep 23:59 20130926-access.log
    -rw-r--r-- 1 root root 676560 27. Sep 21:06 20130927-access.log
    lrwxrwxrwx 1 root root 19 27. Sep 11:05 access.log -> 20130927-access.log
    -rw-r--r-- 1 root root 7268443 27. Sep 21:01 error.log
    -rw-r--r-- 1 root root 264688 3. Jan 2013 error.log.1.gz
    drwxr-xr-x 2 root root 4096 9. Jul 09:49 unzip
    -rw-r--r-- 1 root root 24293 10. Jul 09:17 webalizer.conf
    lrwxrwxrwx 1 root root 19 26. Sep 13:20 yesterday-access.log -> 20130907-access.log
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Are webalizer an AWStats installed on your new server?
     
  5. dwalin

    dwalin New Member

    Yes, both are installed.

    Package webalizer-2.21_02-3.3.el6.x86_64 already installed and latest version
    Package awstats-7.0-3.el6.noarch already installed and latest version
     
    Last edited: Oct 7, 2013
  6. dwalin

    dwalin New Member

    Is there a way to enable logging of the script, which creates the stats? Mayby that gives a hint, what goes wrong.
     
  7. dwalin

    dwalin New Member

    Hi, I just removed webalizer and awstats and tried the daily script with
    " php /usr/local/ispconfig/server/cron_daily.php"
    but no error came up.

    I installed webalizer and awstats again and no stats are generated.

    Has anyone any suggestions?
     
  8. dwalin

    dwalin New Member

    I found a bit more:

    I have created a new website to compare differences between the old sites and a new one.

    I found this:
    On the new site logs are written to to /var/log/ispconfig/httpd/NEWSITE and to /var/www/NEWSITE/log
    On the old site the logs are ONLY written to /var/log/ispconfig/httpd/OLDSITE

    I have manualy copied the logs from /var/log/ispconfig/httpd/OLDSITE to /var/www/OLDSITE/log and at least webalizer created stats.

    When I want to create stats with awstats I get on both sites the following error:
    [[email protected] log]# php /usr/local/ispconfig/server/cron_daily.php
    PHP Warning: rename(/var/www/clients/client1/web1/web/stats/awstats.OLDSITE.de.html,/var/www/clients/client1/web1/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 417
    PHP Notice: Undefined index: admin_notify_priority in /usr/local/ispconfig/server/lib/app.inc.php on line 159
    PHP Notice: Undefined index: admin_mail in /usr/local/ispconfig/server/lib/app.inc.php on line 159
    finished.


    Now I have 1 question:

    How can I fix the error with the undefined index?

    Thanks a lot
     
    Last edited: Oct 21, 2013
  9. dwalin

    dwalin New Member

    I found now the last bits to get it working:

    the /etc/fstab needs to be adjusted, which I seem to forgot after migrating all to the new server and in /etc/awstats was the file "awstats.conf" missing.

    Now I get again all stats

    You can close this thread.

    Thanks
     

Share This Page