Stats doesnt work

Discussion in 'Installation/Configuration' started by Mikobiko, Feb 19, 2010.

  1. Mikobiko

    Mikobiko New Member

    Hello I followed the guide for CentOS 5.4 x64 Perfect Server.

    However stats is not working on any domain.

    You don't have permission to access /stats/ on this server.

    I enter the correct password, and through ssh the stats folder is completely empty. Any ideas?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you installed webalizer and that the webalizer binary is in a normal path like /usr/bin. Also be aware that stats are generated once every 24 hours after the website ahs been accessed the first time, so it might take some time until you see them.
     
  3. Mikobiko

    Mikobiko New Member

    It is in the correct location, it has been over 72hours.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are records in the access log of this website?
    Do you use the latest ispconfig 3 version (3.0.1.6)?
     
  5. Mikobiko

    Mikobiko New Member

    I did exactly what was in the guide. Where do I check the logs for what you are asking for?

    It is 3.0.1.6

    This is populated:

    [​IMG]
     
    Last edited: Feb 20, 2010
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Look into the log directory of the website.
     
  7. infused

    infused New Member

    I have the same issue on Ubuntu following the perfect server guide. I get 401 error, auth required. However, customers username/pass doesn't work.
     
  8. damir

    damir New Member

    Have you tried with user name admin
     
  9. infused

    infused New Member

    Yes, same issue.

    The webalizer dir in /var/www is empty, viewing one of the websites stat dirs in .htaccess gives

    I assume this is correct

    oh... let me see. the htpasswd_stat has admin as the username... So the password you set on the stats dir is that admin's password for stats?

    Right. That works... That should be better documented unless I missed something.
     
    Last edited: Feb 25, 2010
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Thst ok as the statistics use their own password, so the client details (which are for the ispconfig login only) can not work. Just create a new password on the stats tab of the website and then wait a few minutes. The username for this password is "admin", as damir pointed out.
     
  11. dclardy

    dclardy Member

    Where can you the .htpasswd_* file? It is not in my virtual directory.

    From what I can see, the file is not in any site. I have created new sites just to see if it shows up, but it is not there. Am I missing something?
     
  12. jtheed

    jtheed Member HowtoForge Supporter

    It's a hidden file, have you used the ls -al command to have it show all files even hidden ones?
     
  13. dclardy

    dclardy Member

    The file is not there, and it is not created at any point.

    Is there something wrong with the configuration file?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to enter a password on the statistics tab of the website settings and click on save. Then about a minute later, the .htaccess and the .htpasswd file will get created.
     
  15. maror

    maror New Member

    STATS it's work !!

    Tilll has right !! ---> sito --> passs 2 min wwww......com/stats

    login admin
    pass. passs (new your)
     

Share This Page