Statistics not compiling.

Discussion in 'Installation/Configuration' started by thevinster, Sep 14, 2005.

  1. falko

    falko Super Moderator

    What's the output of
    Code:
    crontab -l
    (you must run this as root)?
     
  2. Ovidiu

    Ovidiu Active Member

    here is the output:

    btw. I tried almost everything you have already suggested in this 13-pages post as I did not want to waste your time, but its a no-go.nothing works.
     
  3. falko

    falko Super Moderator

    Then I don't know how to help you from here... We could log in to your server and try to fix it, but that would be paid support then, of course...
     
  4. Ovidiu

    Ovidiu Active Member

    I did not want to appear rude, I am just very frustrated :-(

    can you give me a tip how to debug the webalizer script? to get its output? Like I said, I start it and seconds later I am back at the command prompt...
     
  5. nenad

    nenad ISPConfig Developer

    Tenaka,

    I had very similiar problem.

    Look one page back.

    http://www.howtoforge.com/forums/showthread.php?t=562&page=3

    The problem was in crontab.

    Once when I DELETED crontab file, and RETYPED it from scratch, webalizer scripts were executed from crontab as it should be.

    I don't know why that happened, maybie some buggy character which was invisibble or who knows what, but that is how I resolved the problem.

    Give it a try....

    And drink FANTA - Stay Bamboocha :) :) :) just joking
     
  6. Ovidiu

    Ovidiu Active Member

    retyping did not work either :-(

    can someone tell me which script shopuld create the stats folder? that isn't created either for new sites.
     
  7. falko

    falko Super Moderator

    It's /root/ispconfig/scripts/shell/webalizer.php.
     
  8. Ovidiu

    Ovidiu Active Member

    I contacted falko to get paid support, but one last thing I tried seems to have fixed everything:

    went to ispconfig, login as admin, went to the site that does not produce stat, went to options and below, unchecked
    saved the site, waited some minutes, checked it again and saveed the site again.

    this seems to have helped me, since this morning my stats appeared again. I feel a bit like doing voodoo magic here, try this and pray, try that and pray :D
     
  9. nenad

    nenad ISPConfig Developer

    But you throwed chicken bones all over the place, didn't you? If you didn't maybie that was the problem, 'cos you have to do voodoo magic with bones :) ;)
     
  10. madcrock

    madcrock New Member

  11. gilas

    gilas Member

    I cant see the option

    Dear Tenaka I getting crazy for webalizer that is not working. I tried to use admin interface, select the interested site then click on options but I cant see any itemto check/uncheck about webalizer. I suspect the problem is anywhere.

    Looking into webalizer.php i discovered that there is a query on the table isp_isp_web, field: webalizer_stats but I have not this field. Then I added the field and set it to '1' withouth any result.

    Could you help me please? Thank you!
     
    Last edited: Oct 4, 2006
  12. till

    till Super Moderator

    Which ISPConfig version do you have installed?
     
  13. Ben

    Ben HowtoForge Supporter

    i stillt got the problem not to have any stats on my server. So any ideas where to take a look?
     
  14. till

    till Super Moderator

    The only solution I see is to try to debug the logs.php and webalizer.php files step by step on your server, to see what fails and why they fail.
     
  15. Ben

    Ben HowtoForge Supporter

    good idea ;) WOndering why i did not head it earlier.
    Looks like it does not find webalizer, so i will install it and see then...
     
  16. DaFux

    DaFux New Member

    Maybe slightly off-topic - but I got a question about the statistics in general: How do I comile the statistics more often than once a day? I changed the cron job, but that does not give me more recent statistics until I found out that I have to call

    /root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php

    as well to make sure the latest log entries are available for webalizer.

    So, my question: Does it hurt to run the logs script more than once a day? Is it possible to update just the statiistics of ONE web more frequently and let the others untouched?

    Cheers
    Dafux
    [​IMG]
     
  17. till

    till Super Moderator

    Yes, the statistics will be incorrect if the script is run more then once a day.

    No.
     
  18. codemaster

    codemaster New Member

    Thanks!

    5 years on, and this solution worked perfectly for me as well. Kudos to jmroth!
     

Share This Page