Startup & passphrase

Discussion in 'Installation/Configuration' started by rabrol, Dec 6, 2007.

  1. rabrol

    rabrol New Member

    I just did a new install of ispconfig on Ubuntu 7.10 following the "Perfect Setup".

    I ran into something this time that I didn't last time, and now it causes problems on boot. Basically I was asked to enter pass phrases during setup for RSA & PEM.

    When I reboot the machine, it requires this pass phrase to be entered before it fully starts. It also has to be entered from the console....which will be no good when I move the box to another location!!! Do I need to remove these pass phrases somehow?

  2. edge

    edge Active Member Moderator

    It looks like you did not read the install manuel well enough!

    You will need to recreate the certificate as shown here (message 4):

    Make sure you do NOT password protect it!
    Last edited: Dec 6, 2007
  3. rabrol

    rabrol New Member

    Ok, you caught me. Didn't read the install manual that well. I remade the certificate as described in the threat, but it still asks for passphrase on reboot :-(

    Any other ideas?
  4. edge

    edge Active Member Moderator

    I do not know why you are still having this problem.
    Re-creating the certificates should have fixed it, as this is the only thing that could cause your problem!

    Are you sure you did exactly as told in thread?
    Last edited: Dec 7, 2007
  5. rabrol

    rabrol New Member

    I think so. I issued the following commands :

    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key

    and ran through the process of completing the certificate details. That said, it only asked me once. During the actual install I seem to recall filling this in a number of times.

  6. rabrol

    rabrol New Member

    Anyone got further insights to this. I'm still not able to reboot the machine without keying in the password.
  7. wpwood3

    wpwood3 New Member

    You could try installing ISPConfig again. Your existing webs and configuration should remain intact just like they do for any ISPConfig upgrade.

    Be sure to delete the directoy install_ispconfig, unpack ISPConfig again and start from the beginning of the installation instructions.

    Make sure you answer no in steps 7 & 8.

Share This Page