STARTTLS works on the ubuntu server but no STARTTLS over internet

Discussion in 'Server Operation' started by wcz, Feb 19, 2010.

  1. wcz

    wcz New Member

    Dear Mr. Timme:

    I followed your instruction
    http://www.howtoforge.com/perfect-server-ubuntu-9.10-ispconfig-3
    to have successfully installed Ubuntu 9.10 on Vmware (a Host on Windows
    2003). Thanks very much for the detailed instruction.

    However, I have the same problem as described here:
    http://www.howtoforge.com/forums/archive/index.php/t-24997.html
    i.e., Postfix STARTTLS works to localhost only.

    FROM MY HOST UBUNTU SERVER:
    [email protected]:telnet web.mysite.com 25
    Trying 1**.1**.**.***...
    Connected to mail.mysite.com.
    Escape character is '^]'.
    220 web.mysite.com ESMTP Postfix (Ubuntu)
    ehlo mail.mysite.com
    250-web.mysite.com
    250-PIPELINING
    250-SIZE
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.

    WE SEE 250-STARTTLS

    BUT WHEN I TEST FROM A WINXP OVER INTERNET, I GOT:

    220 web.mysite.com ESMTP Postfix (Ubuntu)
    ehlo mail.mysite.com
    250-web.mysite.com
    250-PIPELINING
    250-SIZE
    250-VRFY
    250-ETRN
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN

    NO 250-STARTTLS

    THIS END UP WITH THAT THE MAIL I SENT OUT WAS DEFINED AS PBL MISTAKES.

    THIS DRIVES ME A LONG TIME! PLEASE GIVE ME AN INSTRUCTION HOW TO FIX IT.

    btw, when I follow the Ubuntu doucumentation, https://help.ubuntu.com/9.10/serverguide/C/index.html, I have the samilar problem.

    THANKS!

    wcz
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you sure that your router forwards port 25 to the correct server?
     
  3. wcz

    wcz New Member

    port 25 is open and pointed to the server.

    Otherwise, telnet mail.domain.com 25 will not be reachable, I believe.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Well, could be possible you have another web server in your LAN that port 25 is forwarded to.
     
  5. wcz

    wcz New Member

    only point port 25

    to one machine, i.e., this Ubuntu server. Please help.
     

Share This Page