SSL Website problem -

Discussion in 'Installation/Configuration' started by PSChild, Nov 9, 2015.

  1. PSChild

    PSChild New Member

    Hello all.

    I usually enter in the forum and read much post to solve any issue, that´s why I don´t have post untill now, but I don´t find any way to fix this SSL cert issue.

    I have a panel running over a Debian Wheezy following "The Perfect Server - Debian Wheezy" guide.

    Now I am setting a SSL cert for a website, so first I assign an IP only to this site, enter in the panel Marked SSL and go to SSL site Tab.
    After filling info in State-Locality-Organization-Organization Unit-Country-SSL Domain (with or without "www")-SSL Action "Create" fields and push save, the panel creates "SSL Key" "SSL Request" and "SSL Certificate".

    I copy the SSL Request and paste in my "" Activate Geotrust RapidSSL panel and in the "Read CSR" paste the ISPConfig3 SSL Request Code.
    The result is FAIL with the following message "Use one-word challenge password (no spaces) containing letters or digits only."
    This seems to be due to challengePassword is "A challenge password"

    I try some things, including changing and comment in the "/etc/ssl/openssl.conf" of Debian but with the SAME results.
    How can I fix this?

    Thanks you very much
    Best Regards
  2. PSChild

    PSChild New Member


    I have created a valid KEY and Request by "openssl req -new -newkey rsa:2048 -nodes -keyout ......."
    I have requested and being acepted this.

    Now I have received by mail the "webserver certificate" and "Intermediate CA".
    I enter in ISPConfig3 and mark the SSL option in website options.
    Copy the generated SSL Key and SSL Request
    Copy the mail SSL Certificate and "Intermediate CA" in SSL Bundle
    Selected SSL Action "Save"
    In the FTP I can see the files....
    I created the domain.cert and intermediate.crt
    I copy into /usr/local/ispconfig/interface/ssl ...

    :mad: and I don´t know how ti continue ...
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The CSR parser from ssls is faulty, its the only website where csr's from ispconfig fail. But we have implemented a workaround for their issue for ispconfig 3.1.
    That's ok so far.

    Thats not related to installing a ssl cert into a website, these certs are usd by ispconfig and are not related to a hosted website on this server.
  4. PSChild

    PSChild New Member

    Ok but doesn´t work. "ERR_SSL_PROTOCOL_ERROR"

    I can see two "domain.vhost" in apache2/sites-available, one of domain.vhost and domain.vhost.err , in this one there are a <VirtualHost IP:80> and <VirtualHost IP:443>

    Can I download or update to version 3.1? is There no other way?
    Last edited: Nov 10, 2015
  5. PSChild

    PSChild New Member

    Ok, manually change .vhost file
    It´s working now.
  6. brody182

    brody182 Member

    fatmike and FSFR like this.

Share This Page