SSL, vhost, and folder

Discussion in 'Installation/Configuration' started by mopi1402, Dec 23, 2016.

  1. mopi1402

    mopi1402 New Member

    I was using Plesk for a while, but ISPConfig seems to be a very good alternative, and it's free, that's why I'm using it for a couple of weeks.

    I installed SSL wildcard certificate on my server, and created a "site" on ISPConfig.
    This is the setting :
    - Domain :
    SSL : Checked
    Document root: /var/www/clients/client5/web5
    - Redirection :
    kind od rediction : "no redirection"
    redirection SEO : "3w.domain.tld => domain.tld"
    Rewrite HTTP to HTTPS : Checked
    - SSL : Empty
    - Options :
    custom php.ini : empty
    apache directives : empty

    Furthermore, my .htaccess is empty (no redirection)

    I don't know why, but my vhost is using port 80, and my "website" is not visible. I only see the "
    Welcome to your website!" powered by ISPConfig.

    If I manally change my virtualhost (/etc/apache2/sites-available/ by replacing port 80 with port 443, I can see my website.
    But I think this is not the good way, because if I change the setting on ISPConfig, vhost is overrided, and my site is not reachable anymore.

    Could you please explain how to fix it ?
    Thank you for your help.
    Last edited: Dec 23, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you have a file /etc/apache2/sites-available/ on your server?
  3. mopi1402

    mopi1402 New Member

    Nop, what is it for ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    It gets generated when there is an error. If there is no error file, then there must be an ssl vhost inside, at least if you did not alter the ispconfig code or vhost template and the change to add an ssl cert is not listed as pending anymore in the jobqueue of the monitor.

    Please check the file /etc/apache2/sites-available/ again, it must contain 2 complete vhosts definitions, the ssl one for port 443 is in the second half of the file, so don't worry when you see a vhost for port 80 only first, scroll down and check the second vhost.
  5. mopi1402

    mopi1402 New Member

    Thank you very much.
    I filled the SSL tab and now the vhost contains two section, one with :80, and the other with :443

    I think I will buy your guide to promote ISPConfig and learn a bit more about this tool.

    edit : Sorry but I don't know how to mark my thread as [solved]

Share This Page