SSL/TLS Pure FTPD

Discussion in 'General' started by bboy8012, Dec 6, 2010.

  1. bboy8012

    bboy8012 New Member

    I have configured pure ftpd to accept TLS connections. I can connect using a local account from the sever securely and clear text, but cant connect from ispc3 site ftp users securely, can do clear text. Any insite to this? Thanks
     
  2. till

    till Super Moderator

    Please enable logging in pure-ftpd and then check the logfiles which error message gets logged.
     
  3. bboy8012

    bboy8012 New Member

    Ive enabled verbose logging and this is what I get

    SysLog:
    Code:
    Dec  7 08:06:09 ubuntuserver1 pure-ftpd: (?@69.97.110.110) [INFO] New connection from 69.97.110.110
    Dec  7 08:06:09 ubuntuserver1 pure-ftpd: (?@69.97.110.110) [DEBUG] Command [auth] [TLS]
    Filezilla:
    Code:
    Status:	Resolving address of djcminuz.com
    Status:	Connecting to 71.42.199.157:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 2 of 50 allowed.
    Response:	220-Local time is now 08:06. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	AUTH TLS
    Response:	234 AUTH TLS OK.
    Status:	Initializing TLS...
    Error:	Connection timed out
    Error:	Could not connect to server
     
  4. falko

    falko Super Moderator

    Did you try both active and passive transfers in your FTP client?
     
  5. bboy8012

    bboy8012 New Member

    Yes falko, I've tried both, it is getting really frustrating. I can connect using my internal IP but not external.
     
  6. till

    till Super Moderator

    Ok,. So thats a problem of your router an not your server. Please check that you forwarded the ftp port and all ports within your passive ftp port range from the router to the server.
     
  7. bboy8012

    bboy8012 New Member

    I followed this guide to activate passive port range

    Code:
    echo "40110 40210" > /etc/pure-ftpd/conf/PassivePortRange
    /etc/init.d/pure-ftpd-mysql restart
    and added the range to my router, and Im still not able to connect.
     
    Last edited: Dec 9, 2010

Share This Page