SSL / Sub-domain issue

Discussion in 'General' started by ITG, Dec 16, 2012.

  1. ITG

    ITG New Member HowtoForge Supporter

    Curious question.

    I have my ispconfig 3.0.4.6 running under centos 6.3.. everything is working fine so far.. i noticed something tonight.

    When i go to https://example.com the correct ssl certificate loads (using sni support with the latest version of chrome).. When i go to https://www.example.com it shows up the wrong domain on the certificate. shows the domain for the panel/server hostname itself.

    Now for DNS, i have a CNAME for www.example.com to point to example.com ...

    I have tried the auto-subdomain as "None" and "www." ... either way, it doesn't seem to be correct...

    Any ideas?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does the example.com vhost list both example.com and www.example.com?

    Did you select a specific IP address for the website in ISPConfig, or did you choose *?
     
  3. ITG

    ITG New Member HowtoForge Supporter

    So I guess I didn't come back and post my own reply eh?

    Falko, thanks for the response! I edited my /etc/httpd.conf and changed the servername to www.itgwebhosting.com which apparently caused issues.. so i changed it to my ip address instead. Once i did that, everything worked fine (after an apache restart).

    To answer your question though, both are in the vhost file and yes i use * for the ip.
     
  4. almere

    almere ISPConfig Developer ISPConfig Developer

    What type of SSL certificate do you have?
     

Share This Page