SSL Sites not working

Discussion in 'General' started by scottrill2, Jan 29, 2011.

  1. scottrill2

    scottrill2 Member

    Brief description of events.

    Yesterday all 6 sites working like a champ. Today only http sites are working. If I go to https://myssldomain.com I receive "Internet Explorer cannot display the webpage" or in firefox "The connection was interrupted".

    If I try going to the regular hhtp for my ssl sites like http://myssldomain.com I get a basic web page that says "It works!". I understand this to be a generic page like placeholder by apache or something.

    I was hoping I could find an error or something so I would have a place to start searching but unfortunately not.

    In /var/www/web1,web2,web4 etc/log/error.log there are zero errors listed for the site.

    In /var/log/apache2/error.log the following notices are given for today.

    [Sat Jan 29 09:15:51 2011] [notice] caught SIGTERM, shutting down
    [Sat Jan 29 09:15:52 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Sat Jan 29 09:15:52 2011] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Sat Jan 29 09:15:52 2011] [notice] mod_python: using mutex_directory /tmp
    [Sat Jan 29 09:15:52 2011] [notice] Apache/2.2.9 (Debian) mod_python/3.3.1 Python/2.5.2 mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Sat Jan 29 09:22:20 2011] [notice] caught SIGTERM, shutting down
    [Sat Jan 29 09:23:15 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Sat Jan 29 09:23:15 2011] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Sat Jan 29 09:23:15 2011] [notice] mod_python: using mutex_directory /tmp
    [Sat Jan 29 09:23:16 2011] [notice] Apache/2.2.9 (Debian) mod_python/3.3.1 Python/2.5.2 mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations
    [Sat Jan 29 09:23:21 2011] [notice] caught SIGTERM, shutting down
    [Sat Jan 29 09:23:23 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Sat Jan 29 09:23:23 2011] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Sat Jan 29 09:23:23 2011] [notice] mod_python: using mutex_directory /tmp
    [Sat Jan 29 09:23:23 2011] [notice] Apache/2.2.9 (Debian) mod_python/3.3.1 Python/2.5.2 mod_ruby/1.2.6 Ruby/1.8.7(2008-08-11) mod_ssl/2.2.9 OpenSSL/0.9.8g configured -- resuming normal operations


    Also I googled a bit for ssl sites not working and saw several results talking about "checking my SSL logs" But I will be damned if I can find them. I have checked the log folders of the individual websites, the SSL folders of the individual websites and var/log folder. Are the ssl logs hidden for security or something?

    How should I proceed in troubleshooting this?

    As always thanks for the help folks,

    Scott
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Usually the SSL error log is in /var/log/apache2/.
     
  3. scottrill2

    scottrill2 Member

    Seems fixed.

    Alright lol,

    I checked my messages and comcast left me a message at midnight on the 28th saying there was a problem with my static IP's and they were switching me to dynamic IPs while they troubleshoot. There was a second message from them early in the morning on the 29th saying the issue had been resolved and they returned my gateway back to the static IP setup.

    I hadn't checked my messages so I was completely unaware this had occured. Just for giggles I reset my gateway, firewall and router and now everything seems fine, all SSL login pages pull up fine etc.

    Since the sites that use SSL have their own static IP, is it possible comcast playing with my gateway could have caused this? Would that explain why there were no error messages at all in the logs?


    Thanks as always folks,

    Scott
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, because you probably had other IP addresses than the ones you use in the Apache configuration. In this case, Apache will show you the first available vhost (which usually is the default vhost which contains the placeholder page).
     

Share This Page