SSL Problem

Discussion in 'General' started by fabien, Jul 27, 2007.

  1. fabien

    fabien New Member

    Hi,

    I am a newb with linux. I installed fedora 7 (with howtoforge) and isp config.
    Then i've created a website on http. And everything is working. But, I want to use ssl too. So i've created a ssl certificate thx to ispconfig. but when i do https://mydomain.com, i obtain "unable to connect..."
    My firewall allows port 443.
    The firewall in ispconfig is off.
    But when i go to ispconfig, tools, portscanner, I obtain this:

    Port 21 (tcp) is open (ftp)!
    Port 22 (tcp) is open (ssh)!
    Port 25 (tcp) is open (smtp)!
    Port 80 (tcp) is open (http)!
    Port 81 (tcp) is open (ISPConfig)!
    Port 110 (tcp) is open (pop3)!
    Port 111 (tcp) is open (sunrpc)!
    Port 143 (tcp) is open (imap)!
    Port 631 (tcp) is open (ipp)!
    Port 945 (tcp) is open (unknown)!
    Port 993 (tcp) is open (imaps)!
    Port 995 (tcp) is open (pop3s)!
    Port 2207 (tcp) is open (unknown)!
    Port 2208 (tcp) is open (unknown)!
    Port 3306 (tcp) is open (mysql)!

    I should have port 443, isn't it????

    Thx.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please configure your webserver to listen on port 443. Have a look at the perfect setup guide for your linux distribution for detailed instructions.
     
  3. fabien

    fabien New Member

    For the installation of fedora, I have followed the installation of fedora 7 perfect server. But I don't know why, the ssl port (443) is not opened, and I can't find why. The firewall and SE Linux of the web server are disable. I really don't know what to do to open it...
     
  4. fabien

    fabien New Member

    so to confirm ispconfig.

    port 80 is governed by /root/ispconfig/httpd/conf/httpd.conf
    port 81 is governed by /root/ispconfig/httpd/conf/????????????
    port 443 is governed by /root/ispconfig/httpd/conf/??????????????


    as my port test shows 443 is not running, so what do i need to do to enable 443, but leave 81 for my admin alone..


    cheers fabien
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up the ispconfig webserver with the main webserver of your linux distribution. Did you add port 80 in /root/ispconfig/httpd/conf/httpd.conf ? You must remove it there, otherwise your main webserver will nor work and you will not be able to host websites on your server.

    Then restart the ispconfig_server and afterwards start your main webserver.
     
  6. fabien

    fabien New Member

  7. fabien

    fabien New Member

    please help, cannot make 443 work properly...


    please post reply
     
  8. falko

    falko Super Moderator ISPConfig Developer

    I can reach any of them...
    What's the output of
    Code:
    netstat -tap
    and
    Code:
    ls -la /root/ispconfig
    ? Any warnings in /home/admispconfig/ispconfig/ispconfig.log?

    Please make sure your ISP doesn't block the ports 80 and 443.
     
  9. fabien

    fabien New Member

    I don't know where was the problem, so i wiped it and started over yesterday.
    Now it is working perfectly fine.
    Thanx all.
     

Share This Page