SSL pages fail to load

Discussion in 'Installation/Configuration' started by RonnyMc, Apr 23, 2010.

  1. RonnyMc

    RonnyMc New Member

    Greetings Everyone,

    I will start by apoligizing if this has been asked and answered but I have searched through the forums and google and found offered solutions and none have worked.

    I have installed ISPConfig version on a CentOS 5.4 server and mostly everything seems to be working, expect I cannot load any SSL pages.

    Following are things I have tried:
    1. Verified that the conf files we using an IP address and not the asterik(*)
    2. Verified that the conf file for the domain has the VirtualHost info for 443
    3. Verified the server allowed port 443 (even closed IPTables completely and used only the built in firewall)
    4. Verified that the conf file was listening to port 443
    5. Verified the path of the SSL root directory and that it had accessible documents in it
    6. Attempted to find any errors about 443 or SSL in the logs and cannot find anything (if there is a specific place or command to do this please let me know)
    7. Rebooted entire server not just httpd and ispconfig (when all else fails punt!)
    8. Verified that ISPConfig was writing the cert details to the SSL folder

    I really do not know what else to try. At this point I am ready to uninstall and try ISPConfig 2 or not use it at all. I have to finish this server and SSL is kind of an important feature.

    Let me thank you in advance for any consideration and support you can offer me.

  2. RonnyMc

    RonnyMc New Member


    While I installed CentOS 5.4 following the Perfect Server tutorial for 5.3 i386 option, I have also check the 5.4 x64 tutorial and it states "that offers all services needed by ISPs and web hosters: Apache web server (SSL-capable)". After reading that and checking the Apache install section of the tutorial it matches the 5.3 one. Thus, I am further confussed. As I checked and mod_ssl was not installed nor any of the cert.pems?

    Am I wrong or does this not need to be installed? Could someone please assist as I really need to get SSL working on this server.

  3. RonnyMc

    RonnyMc New Member

    Update #2:

    After installing mod_ssl the server is not loading SSL pages.

    But now I am having an issue where when I create the first domain everything works, but when I add a second domain it blows out the SSL VirtualHost from the .conf file.

    Is this something I did or is it a bug?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Make sure that you assigned a dedicated IP address to every website where you enable ssl. Thats required by the SSL specification.
  5. charlesrg

    charlesrg New Member

    Same Problem Here

    The system generates the Certificates at /var/www/
    But it does not generate the SSL parameters for the Vhost.

    What is the logic that checks if the SSL Parameters for the vhost should be generated or not ?

    Here I have one IP per domain, everything should be fine but it does not generates it.

Share This Page