SSL on email server not working after upgrading to 3.2

Discussion in 'Installation/Configuration' started by Stelios, Oct 16, 2020.

  1. Stelios

    Stelios Member

    As per the title, on a multi-server setup, SSL is not working (TLS) on email servers. It used to work fine before the update.

    I read somewhere that you can request now SSL into the dovecot etc direct from the control panel but can't find where it is.
    Any help is very much appreciated.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's done during update. rerun the update on that node and choose to create a new SSL cert during update.
     
  3. Stelios

    Stelios Member

    Further to my post when I tried to --force the update in order to select from installer to re-generate the SSLs it just ignore the --force parameter:

    Code:
    [email protected]:~# ispconfig_update.sh --force
    >> Update 
    Please choose the update method. For production systems select 'stable'.
    WARNING: The update from GIT is only for development systems and may break your current setup. Do not use the GIT version on servers that host any live websites!
    Note: On Multiserver systems, enable maintenance mode and update your master server first. Then update all slave servers, and disable maintenance mode when all servers are updated.
    Select update method (stable,nightly,git-develop) [stable]:
    
    There are no updates available for ISPConfig 3.2
    If you are sure you want to update to stable anyway, please use --force parameter
    DOWNGRADING MAY CAUSE ISSUES!
    [email protected]:~#
    
     
  4. Stelios

    Stelios Member

    I download the files and run the update.php directly and worked. Thanks a lot
     

Share This Page