SSL on domains

Discussion in 'Installation/Configuration' started by DKLeader, Oct 9, 2010.

  1. DKLeader

    DKLeader New Member

    Hi,

    Searched and tried almost all the suggestions that I could find but cannot find why my SSL is not working.

    I am runinng multiservers (5 servers) setup and each running Debian Lenny.

    I have tried getting this to work on my domain coolride.dk :

    This is what I have done and checked :

    My interface looks like this :
    Code:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    # allow-hotplug eth0
    auto eth0
    iface eth0 inet static
    address 192.168.1.90
    netmask 255.255.255.0
    gateway 192.168.1.1
    
    auto eth0:0
    iface eth0:0 inet static
    address 192.168.1.91
    netmask 255.255.255.0
    
    auto eth0:1
    iface eth0:1 inet static
    address 192.168.1.92
    netmask 255.255.255.0
    
    auto eth0:2
    iface eth0:2 inet static
    address 192.168.1.93
    netmask 255.255.255.0
    
    auto eth0:3
    iface eth0:3 inet static
    address 192.168.1.94
    netmask 255.255.255.0
    
    # auto eth0
    
    I have tried to ping the IP's from another server on the network and had no problem on doing that.

    From the the coolride.dk.vhost :
    Code:
    <Directory /var/www/coolride.dk>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <VirtualHost 192.168.1.91:80>
          DocumentRoot /var/www/coolride.dk/web
    
        ServerName coolride.dk
        ServerAlias www.coolride.dk
        ServerAdmin [email protected]
    
        ErrorLog /var/log/ispconfig/httpd/coolride.dk/error.log
    
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/coolride.dk/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client1/web2/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    
        # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # php as fast-cgi enabled
        <IfModule mod_fcgid.c>
          # SocketPath /tmp/fcgid_sock/
          IdleTimeout 3600
          ProcessLifeTime 7200
          # MaxProcessCount 1000
          DefaultMinClassProcessCount 3
          DefaultMaxClassProcessCount 100
          IPCConnectTimeout 8
          IPCCommTimeout 360
          BusyTimeout 300
        </IfModule>
        <Directory /var/www/coolride.dk/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
            <Directory /var/www/clients/client1/web2/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web2 client1
        </IfModule>
    
        <IfModule mod_dav_fs.c>
          # DO NOT REMOVE THE COMMENTS!
          # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
          # WEBDAV END
        </IfModule>
    
    
    </VirtualHost>
    
    
    
    <IfModule mod_ssl.c>
    ###########################################################
    # SSL Vhost
    ###########################################################
    
    <VirtualHost 192.168.1.91:443>
          DocumentRoot /var/www/coolride.dk/web
    
         ServerName coolride.dk
        ServerAlias www.coolride.dk
        ServerAdmin [email protected]
    
        ErrorLog /var/log/ispconfig/httpd/coolride.dk/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        SSLEngine on
        SSLCertificateFile /var/www/clients/client1/web2/ssl/coolride.dk.crt
        SSLCertificateKeyFile /var/www/clients/client1/web2/ssl/coolride.dk.key
    
            <Directory /var/www/coolride.dk/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
        <Directory /var/www/clients/client1/web2/web>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
    # Clear PHP settings of this website
        <FilesMatch "\.ph(p3?|tml)$">
            SetHandler None
        </FilesMatch>
        # php as fast-cgi enabled
        <IfModule mod_fcgid.c>
          # SocketPath /tmp/fcgid_sock/
          IdleTimeout 3600
          ProcessLifeTime 7200
          # MaxProcessCount 1000
          DefaultMinClassProcessCount 3
          DefaultMaxClassProcessCount 100
          IPCConnectTimeout 8
          IPCCommTimeout 360
          BusyTimeout 300
        </IfModule>
        <Directory /var/www/coolride.dk/web>
             AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
            <Directory /var/www/clients/client1/web2/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride All
            Order allow,deny
            Allow from all
        </Directory>
    
        # add support for apache mpm_itk
        <IfModule mpm_itk_module>
          AssignUserId web2 client1
        </IfModule>
    
        <IfModule mod_dav_fs.c>
          # DO NOT REMOVE THE COMMENTS!
          # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
          # WEBDAV END
        </IfModule>
    
    
    </VirtualHost>
    </IfModule>
    
    I ran this
    and got this :
    I have checked that the cert files are in in ssl folder.

    Port 443 is opened on the router for 196.168.1.90.

    Anyone got an idea to what I have missed?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the problem. You have to forward port 443 from your router to the server IP address 192.168.1.91 if the ssl site is on that IP.

    If you want to use multiple internal IP addresses, you need to have the same amount of external IP addresses and then forward every external IP separately to a internal IP.
     

Share This Page