SSL of Thawte will be safed as a own certificate

Discussion in 'Installation/Configuration' started by AndréS, Sep 14, 2007.

  1. AndréS

    AndréS New Member

    Hello,

    for a client I installed a certificate. This is a official certificate. It is from thawte.
    I sent the Request to thawte and imported the CA from thawte. But all the times, all Browser says, "Error" It is a Certificate from the website self. But this is wrong.

    you can see this: https://shop-schwarzes-gesoxx.de

    How can I repair this?

    By the way I changed the CA and got a new CA for a new Request.


    Thanks a lot


    André
     
  2. catdude

    catdude ISPConfig Developer ISPConfig Developer

    Check the cert first

    Does “openssl req –text –noout –in <your certificate file>” display Thawte as the issuer?
     
  3. AndréS

    AndréS New Member

    Even in the explorer he says that thawte isn´t the issuer.

    I will look into the file, but I think not.:(
     
  4. daveb

    daveb Member

    After the install of cert did you try to restart apache. You might try that.
     
  5. the_spy

    the_spy New Member

    you need to call the domain with the "www" since you bought the ssl certificate with www included in the domain
     
  6. AndréS

    AndréS New Member

    Yes I did a restart, but not because the installation of ther cert. But it was after I installed the cert. Okay, I retry it :)

    No wíth www. is nothing changed. Still the problem.
     
  7. AndréS

    AndréS New Member

    Now I tried this:

    1: I deleted the cert
    2: I pasted the Request (I saved them before) into Request
    3: I pasted the cert into cert

    Result: error!! The website cannot displayed.
     
  8. the_spy

    the_spy New Member

    it was working here with the www. I got just one error before only due to the missing www in the url.
     
  9. AndréS

    AndréS New Member

    Sorry but here I saw the wrong cert. And the client too.
    Evrey time the browser says it is a self criated cert. :-(
     
  10. the_spy

    the_spy New Member

    Ok I saw the error, I forgot I accepted the certificate one time so the url with www was giving no error since I already accepted the certificate.
    Actually yes it is the self signed certificate which appear and not the Thawte one.
    I already use a Thawte certificate for 2 of my sites and it works correctly with adding them simply in ispconfig, so if you follow the instructions for ssl certificate for ispconfig then it should be ok. You may need to restart apache after adding the ssl certificate, but it was fixed just in the last ispconfig version normally so it should reboot itself.
     
  11. AndréS

    AndréS New Member

    Yo, after a restart the apache was down and not restartable.

    The error log show this:
    What have I to do????
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure that you copied the complete certificate and that you copied it to the correct field, e.g. that you did not mix up csr and crt?
     

Share This Page