SSL not working in admin module after Letsencrypt renewal

Discussion in 'Installation/Configuration' started by Niels Terp, Nov 21, 2019.

  1. Niels Terp

    Niels Terp New Member

    Hi,
    I'm running a ispconfig 3 server for a customer. I have used the guide https://www.howtoforge.com/tutorial/securing-ispconfig-3-with-a-free-lets-encrypt-ssl-certificate/ to secure the admin panel. Initialy this worked fine, but at some point of time the certs were renewed - and then I could no longer access the admin panel.
    I follow above guide again, the certs now have a '2' in their filename, so I just generate a new set of keys. But now it is not working anymore. I have tried a lot of browsers(ms edge, firefox, chrome, opera) but they all reports 'Possible attack detected'. Only in a very old safari browser can I open the admin panel.
    What I would like is to completely uninstall letsencrypt, then install it again from scratch. Is this possible ?

    Cheers
    Niels
     
  2. ahrasis

    ahrasis Well-Known Member

    You have to restart incron after that tutorial and ensure incron service is always running. Monitor incron with monit if you have to as the tutorial heavily relies on incron for the renewal process.
     

Share This Page