SSL not working for individual site.

Discussion in 'General' started by FeraTechInc, Mar 1, 2007.

  1. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    I recently tried to install zencart with SSL support. However, I have been having some problems.

    1. I enabled SSL for the site. Installed the cart then when I tried to access the admin section via SSL I got a -12263 error.

    So I edited /root/ispconfig/httpd/conf/httpd.conf and changed SSL to 443

    The I edited /etc/apache2/ports.conf and commented out port 443

    2. Now when I try to get to the admin section I get a page does not exist error. So have I made progress or have I actually gone backwards?

    Some detailed help from ANYBODY who has set up an SSL site using ISPConfig would be GREATLY appreciated.

    I have set up ISPConfig originally to use SSL to log in, if that has anything to do with my problem.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Undo what you did in 1). Never edit this configuration file. You mix up the webserver that serves the controlpanel and the webserver that serves your websites.

    The error in 2 results in editing the file in 1.

    After you have undone everything you described above and are able to login again:

    Have you created a SSL certificate by filling out the fields on the SSL tab of the website and then select "Create" as action to create the ssl certificate?
     
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Do you use a dedicated IP for the site you want SSL on? You can not have multiple sites with SSL on one IP. One SSL cert == one IP
     
  4. FeraTechInc

    FeraTechInc ISPConfig Developer ISPConfig Developer

    I did that but nothing appeared in the "SSL Request:" box after I created the SSL certificate...
     
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    What version of ISPConfig do you use?
     

Share This Page