SSL not created

Discussion in 'Installation/Configuration' started by Steffan, Oct 24, 2016.

  1. Steffan

    Steffan Member

    Hello,

    i have a site ( and there are more not all sites)
    when enabling SSL (with or without let's encrypt)
    The vhost file is not updated.
    The complete 443 section is missing.
    Also no vhost.err file

    any idees how to debug this problem.
     
  2. oNdsen

    oNdsen New Member HowtoForge Supporter

    Do you have a Multiserver Setup or a single Server?
    Any Messages in Syslog? What do you get when you run your server.sh manual?
    Code:
    sh /usr/local/ispconfig/server/server.sh
     
  3. Steffan

    Steffan Member

    Multi, but web is on this server

    the cron is running with no errors when running manualy
    let's encrypt is generating the certs

    notting in /messages/
    httpd error log
    ispconfig.log
    the complete
    <VirtualHost *:443>
    </VirtualHost>

    isnt added to the vhost config
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Steffan

    Steffan Member

    hm that is strange
    i put debug on
    try again and now it is working.

    Past 4 times failed.
     
  6. Steffan

    Steffan Member

    Problem is back.
    In debug mode i dont see anything wrong.
    No 443 section is created :-(
    i removed the site completely
    Regenerated it but still no 443 section in the config


    20.02.2017-14:35 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    20.02.2017-14:35 - DEBUG - Found 1 changes, starting update process.
    20.02.2017-14:35 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    20.02.2017-14:35 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    20.02.2017-14:35 - DEBUG - Create Let's Encrypt SSL Cert for: xxx.nl
    20.02.2017-14:35 - DEBUG - Let's Encrypt SSL Cert domains: xxx.nl --domains www.xxx.nl
    which: no letsencrypt in (/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin)
    which: no certbot in (/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin)
    20.02.2017-14:35 - DEBUG - exec: /root/.local/share/letsencrypt/bin/letsencrypt certonly -n --text --agree-tos --expand --authenticator webroot --server https://acme-v01.api.letsencrypt.org/directory --rsa-key-size 4096 --email [email protected] --domains xxx.nl --domains www.xxx.nl --webroot-path /usr/local/ispconfig/interface/acme
    /root/.local/share/letsencrypt/lib/python2.6/site-packages/cryptography/__init__.py:26: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6
    DeprecationWarning
    Saving debug log to /var/log/letsencrypt/letsencrypt.log
    You are running with an old copy of letsencrypt-auto that does not receive updates, and is less reliable than more recent versions. We recommend upgrading to the latest certbot-auto script, or using native OS packages.
    Cert not yet due for renewal
    Keeping the existing certificate
    20.02.2017-14:35 - DEBUG - Writing the vhost file: /etc/httpd/conf/sites-available/xxx.nl.vhost
    20.02.2017-14:35 - DEBUG - Writing the PHP-FPM config file: /etc/opt/remi/php70/php-fpm.d/web849.conf
    20.02.2017-14:35 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    20.02.2017-14:35 - DEBUG - Restarting php-fpm: service php70-php-fpm reload
    20.02.2017-14:35 - DEBUG - Apache status is: running
    20.02.2017-14:35 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    20.02.2017-14:35 - DEBUG - Restarting httpd: service httpd restart
    20.02.2017-14:35 - DEBUG - Apache restart return value is: 0
    20.02.2017-14:35 - DEBUG - Apache online status after restart is: running
    20.02.2017-14:35 - DEBUG - Processed datalog_id 27627
    20.02.2017-14:35 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
     
  7. Jesse Norell

    Jesse Norell Active Member

    So letsencrypt is working, it's just not renewing your certificate because it's not needed. I'd try disabling ssl and letsencrypt checkboxes for the site, hit save and wait a minute - then manually clean up the files for that domain under /etc/letsencrypt/* - then enable the letsencrypt checkbox for the site again.
     
  8. Steffan

    Steffan Member

    Sorry my last post wasnt updated

    Removing the certs fixed the 443 part

    but i dont understand why it was removed
    Both ssl and letsencrypt are enabled.
     

Share This Page