SSL Issue - same content on multiple domains

Discussion in 'Installation/Configuration' started by SSullivan, Aug 18, 2014.

  1. SSullivan

    SSullivan New Member

    Hi. I have an issue with SSL on multiple domains.

    I have a set-up whereby 1 IP address serves multiple SSL connections.

    1. If I enable SSL on one domain this domain is the default SSL connection for all other non-SSL enabled websites. This is a problem as it shows the SSL content. The only way to fix this is to make sure the SSL enabled website redirects back to it's own domain (otherwise Google accepts this error SSL certificate and indexes it under different domains).
    2. Even if the above fix is in place I do not believe it's good practice for the non-SSL enabled domain to be accessed via SSL. For example one client's website when accessed by SSL redirects them to the SSL enabled website.

    Has anyone got an experience like this?

    Last edited: Aug 18, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What you describe is the normal behaviour of the apache and nginx webserver. Normally you should not use a shared IP address for ssl and non ssl websites as webserevs will show the content of the best matching website.

    If you dont have a second IP address, then you can create a default website to catch the ssl requests of the other sites by adding a website thats first in alphabet like 000domain.tld". The domain does not has to exist. And then enable ssl on that site.

Share This Page