SSL issue, connection refused on port 8080

Discussion in 'Installation/Configuration' started by timothylegg, Oct 10, 2013.

  1. timothylegg

    timothylegg New Member

    Hello,

    I installed this on Ubuntu 12.4.3 LTS (Precise)

    I downloaded this code from:


    I followed the document:


    The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)
    http://www.howtoforge.com/perfect-server-ubuntu-12.04-lts-apache2-bind-dovecot-ispconfig-3

    I deviated from the document by:

    • Router assigned a DHCP address of 10.0.1.171 based on the mac address of my computer. /etc/network/wireless is set to default
    • Omitted PureFTP
    • Omitted Quota

    After completing Step 22 on Page 7 of the document, I couldn't get the ISPConfig page to load. Connection refused. I made an attempt to reinstall, and was suggested to use update.php instead. I opted to create new keys. Didn't accomplish much of a change. Of course, for security and privacy reasons, I substituted my domain name with example.com and obfuscated my IP address.

    wget https://www.example.com:8080
    --2013-10-10 13:50:06-- https://www.example.com:8080/
    Resolving www.example.com (www.example.com)... 76.10.x.x
    Connecting to www.example.com (www.example.com)|76.10.x.x|:8080... failed: Connection refused.​

    So I see above where my web browser got the idea that the connection was refused. Let's see what happens with localhost instead.

    wget https://localhost:8080
    --2013-10-10 13:50:56-- https://localhost:8080/
    Resolving localhost (localhost)... 127.0.0.1
    Connecting to localhost (localhost)|127.0.0.1|:8080... connected.
    ERROR: cannot verify localhost's certificate, issued by `/C=AU/ST=Some-State/O=Internet Widgits Pty Ltd':
    Self-signed certificate encountered.
    ERROR: certificate common name `' doesn't match requested host name `localhost'.
    To connect to localhost insecurely, use `--no-check-certificate'.​

    Okay, I'm given a hint as to how to get this page loaded. Let's go for it:

    wget --no-check-certificate https://localhost:8080
    --2013-10-10 13:51:39-- https://localhost:8080/
    Resolving localhost (localhost)... 127.0.0.1
    Connecting to localhost (localhost)|127.0.0.1|:8080... connected.
    WARNING: cannot verify localhost's certificate, issued by `/C=AU/ST=Some-State/O=Internet Widgits Pty Ltd':
    Self-signed certificate encountered.
    WARNING: certificate common name `' doesn't match requested host name `localhost'.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: `index.html'
    2013-10-10 13:51:39 (9.65 MB/s) - `index.html' saved [9199]​

    I guess I should admit that I don't know much about how keys work. I haven't had much progress with interpreting the documentation over the last decade.

    What have I missed and where do I read up on that?

    Tim Legg
     
    Last edited: Oct 11, 2013
  2. timothylegg

    timothylegg New Member

    I may have identified the problem. I tested port 443 with nc on a intranet machine as well as on a proxy machine 30 miles away. Yes, the router didn't block that traffic. But it did block port 8080. I for some reason had it in my mind that the webpage was using 443, despite typing 8080 right into the URL. I feel sort of stupid I spent 3-4 hours reading newsgroups, FAQs and wiki pages over this to have it be an oversight of port privileges.

    Can't change the router settings for a few hours...
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    you can change the ispconfig port in the file /etc/apache2/sites-available/ispconfig.vhost
     

Share This Page