SSL in domain

Discussion in 'General' started by qb7, Jul 19, 2011.

  1. qb7

    qb7 New Member

    I made one ssl certificate in a domain, and not run. When point https://www.mydomain.com in broser, the result is apache http server test Page powered. After this i did erase the certificate and don't run when point http://www.mydomain.com. The result is other domain park in the server. Why? Please hep my to this big problem for my.

    ispconfig 3.0.3.2 CentOS. 5.5

    Thank
     
  2. qb7

    qb7 New Member

    SSL problem wich domain

    Is posible wich cron job solution for this issue:(
     
  3. qb7

    qb7 New Member

    No isn't cron job solution.

    How I most go back the process to ssl domain in ispconfig, for normal fuction: http://www.mydomain.com?
    Please help me the domain is in production.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you download the ISPConfig 3 Manual? If so, please check out chapter 5.4.
     
  5. qb7

    qb7 New Member

    I read 5.4 capitulo

    Hi Falko I don't have the solution. This domain now when I going point the broser http://www.mydomain.com, the broser show me other web, the next alphabetical order. When I pointing the broser https://www.mydomain.com, the broser show me the page Apache 2 Test Page powered by CentOS.

    The sistem is IspConfig 3.0.2 and run in Centos 5.5

    Only change the mode SSL in domain and not work.

    I see this post http://www.howtoforge.com/forums/showthread.php?t=41597 how to made this for one posible solution? post of Till.
    :confused:
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post the vhost configurations for the mydomain.com http and https vhosts?
     
  7. qb7

    qb7 New Member

    I find the error and possible issue

    I have to put in the web site of domain the wildcard (*) in ip field and them run ok: www.mydomain.com
    If I put the ip 111.111.111.111 them not run. This ip is the same wich the server IP (the internet static IP wich i have of my internet provider).

    If the SSL is active them https:// show me the page of server other time.

    How I can put SSL in only one domain?


    The issue wich I find is:

    When I disable one web site in the server and after I point the broser in the domain disable, the broser show me the page of the next alphabetical order domain active.

    This is from my point of view one issue (hole).

    Sistem: Centos 5.5 IspConfig 3.0.3.2
    Can I report this issue?
     
    Last edited: Jul 25, 2011
  8. qb7

    qb7 New Member

    When point https://www.mydomain.com

    this is the cert to show in the broser:

    pantalla1.jpg
     
  9. falko

    falko Super Moderator ISPConfig Developer

    What about my question in post #6?
     
  10. qb7

    qb7 New Member

    I have solved this problem

    Hello to all, I have solved this problem in my system:

    Centos 5.5

    IspConfig 3.0.3.3 (I upgrade it)

    In the ssl.conf (etc/httpd/conf.d/ssl.conf) I have applied this policy

    <IfDefine 0>
    ##
    ## SSL Virtual Host Context
    ##

    <VirtualHost _default_:443>
    ...
    </VirtualHost>
    </IfDefine>

    This fixed the default vhost and run OK the cert of mydomain.

    Thank Falko
     

Share This Page