SSL IMAP not working; Couldn't unlink "/var/run/postgrey.pid" [Permission denied]

Discussion in 'Installation/Configuration' started by Dark Magician, Apr 13, 2020.

  1. Dark Magician

    Dark Magician New Member

    **EDIT - FIXED**

    After update-ing the server incoming SSL on IMAP no longer works. SSL on websites/ispconfig and IMAP without SSL also work fine.
    When I check the logs I see:

    Couldn't unlink "/var/run/postgrey.pid" [Permission denied]

    I have a feeling this is the reason incoming server with SSL for imap is no longer working but i'm plucking my hair out on how to fix this.
    I restored an backup but when I update it breaks again.
     
    Last edited: Apr 14, 2020
  2. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    Issues with postgrey won't have anything to do with your imap server.

    As for imap, after updating your server, try updating to the latest ISPConfig version and let it reconfigure services. (If you're already on the latest release, either update to git-stable or manually download the latest release and run update.php from there.)
     
    Dark Magician likes this.
  3. Dark Magician

    Dark Magician New Member

    **EDIT - FIXED**

    Fixed it by running all the steps from the perfect server for Debian Buster, could run the update and reconfigure. All is well now.

    --BELOW NO LONGER IMPORTANT--
    I ran
    # cd /tmp && wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    # tar xfz ISPConfig-3-stable.tar.gz && cd ispconfig3_install/install/
    # php -q update.php


    Which gave me the following output:

    >> Update

    Operating System: Debian 10.0 (Buster) or compatible

    This application will update ISPConfig 3 on your server.

    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:

    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    Checking ISPConfig database .. OK
    PHP Fatal error: Uncaught Error: Call to undefined function mb_detect_encoding() in /tmp/ispconfig3_install/install/lib/mysql.lib.php:448
    Stack trace:
    #0 /tmp/ispconfig3_install/install/lib/mysql.lib.php(166): db->escape('validate_passwo...')
    #1 /tmp/ispconfig3_install/install/lib/mysql.lib.php(231): db->_build_query_string('SELECT plugin_n...', Array)
    #2 /tmp/ispconfig3_install/install/lib/mysql.lib.php(270): db->_query('SELECT plugin_n...', Array)
    #3 /tmp/ispconfig3_install/install/lib/mysql.lib.php(319): db->query('SELECT plugin_n...', Array)
    #4 /tmp/ispconfig3_install/install/lib/update.lib.php(139): db->queryAllRecords('SELECT plugin_n...', Array)
    #5 /tmp/ispconfig3_install/install/update.php(315): updateDbAndIni()
    #6 {main}
    thrown in /tmp/ispconfig3_install/install/lib/mysql.lib.php on line 448
     
    Last edited: Apr 14, 2020

Share This Page