SSL for website not working on ISPConfig 3.1b1

Discussion in 'Installation/Configuration' started by DonMcCoy, Jul 31, 2016.

  1. DonMcCoy

    DonMcCoy New Member HowtoForge Supporter

    Hello, I am testing the new beta SPConfig 3.1b1 and everything looks good except the SSL for websites which i can't add it through ISPConfig.

    what i have done:

    i ticked the SSL in mysite.tld domain page, then on the SSL window I've added my SSL Certificate and the SSL Bundle and choose save certificate action.

    when checking the SSL folder:
    i can see that the certificate is saved (the SSL and the Bundle is merged in one file, is that correct?)

    but when i check the vhost file:
    i don't see any change or declaration of the SSL cert location (is it a Bug or i should add it manually?)

    when i tried to add it manually in the vhost file like the following:

    Code:
    listen *:80;
                ssl on;
                ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
                ssl_certificate /var/www/clients/client3/web4/ssl/cert_chain.crt;
                ssl_certificate_key /var/www/clients/client3/web4/ssl/mysite.tld.key;
                        
    it's also failing to handle SSL Engine on port 80 until i change the port to 443. and it will work probably then.

    so what am i doing wrong, any idea is highly appreciated.
    thanks
     
  2. DonMcCoy

    DonMcCoy New Member HowtoForge Supporter

    UPDATE:

    It worked finally the SSL certificates where saved Successfully and the vhost where edited accordingly to be:

    Code:
    listen *:80;
            listen *:443 ssl;
            ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
            ssl_certificate /var/www/clients/client3/web4/ssl/turkeyworking.com.crt;
            ssl_certificate_key /var/www/clients/client3/web4/ssl/turkeyworking.com.key;
    
            server_name turkeyworking.com www.turkeyworking.com;
    which is listening on port 80 and port 443 for SSL connection.

    and ticked the option "Rewrite HTTP to HTTPS" (in Redirect window) to redirect the requests from HTTP to HTTPS.

    what I've done: is filling all the fields in SSL (SSL Key, SSL Request, SSL Certificate and SSL Bundle) with my signed Certificate.
    and waited for 15 minutes then ISPConfig did it. :):)
     

Share This Page