SSL for site

Discussion in 'ISPConfig 3 Priority Support' started by JESUSSAVES, Apr 29, 2014.


    JESUSSAVES New Member


    Can't get SSL to work for a site. I have a class 2 certificate installed.

    Debian Wheezy with ISPConfig

    I checked SSL box, selected external IP (added as eth0:0 inet static and restarted network), went to SSL tab put in my key & crt, drop down selected "save certificate" and pressed save. Yes, I also added IP under config server.

    But it's not working.

    I looked at the vhost record and IP was there only but still had port 80. So I changed that to port 443 and added 3 lines
                    SSLEngine On
                    SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
                    SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
                    SSLCACertificateFile /usr/local/ispconfig/interface/ssl/
    Now it's working. But how can I get it to work through the control panel?
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have you checked if there is a .err file in the sites-available directory?

    JESUSSAVES New Member

    Oh, I also added 1 record to apache2/ports.conf - forgot to mention that.

    No there is not an .err file in sites-available directory, just the two usual . files.

    I undid it: IP back to *, unchecked SSL box and deleted certificate,. Then put it all back in again but it's still not working.

Share This Page