SSL Error

Discussion in 'Installation/Configuration' started by parkerj, Sep 12, 2009.

  1. parkerj

    parkerj Member HowtoForge Supporter

    I added an SSL certificate to one of my sites, but it comes up with an 500 Eternal Error when trying to access over SSL. Below is what is found in the error log:

    Code:
    [Fri Sep 11 17:54:44 2009] [error] [client 71.233.150.173] SecurityException in Application.cpp:440: Handler not found in configuration
    [Fri Sep 11 17:54:44 2009] [error] [client 71.233.150.173] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-php" not found
    [Fri Sep 11 17:54:44 2009] [error] [client 71.233.150.173] Premature end of script headers: index.php
    [Fri Sep 11 17:54:46 2009] [error] [client 71.233.150.173] SecurityException in Application.cpp:440: Handler not found in configuration
    [Fri Sep 11 17:54:46 2009] [error] [client 71.233.150.173] Caused by KeyNotFoundException in Configuration.cpp:234: Handler "x-httpd-php" not found
    [Fri Sep 11 17:54:46 2009] [error] [client 71.233.150.173] Premature end of script headers: index.php
    Also, below is what is found in my suphp.conf file:

    Code:
    [global]
    ;Path to logfile
    logfile=/var/log/suphp/suphp.log
    
    ;Loglevel
    loglevel=info
    
    ;User Apache is running as
    webserver_user=www-data
    
    ;Path all scripts have to be in
    docroot=/var/www
    
    ;Path to chroot() to before executing script
    ;chroot=/mychroot
    
    ; Security options
    allow_file_group_writeable=false
    allow_file_others_writeable=false
    allow_directory_group_writeable=false
    allow_directory_others_writeable=false
    
    ;Check wheter script is within DOCUMENT_ROOT
    check_vhost_docroot=true
    
    ;Send minor error messages to browser
    errors_to_browser=false
    
    ;PATH environment variable
    env_path=/bin:/usr/bin
    
    ;Umask to set, specify in octal notation
    umask=0022
    
    ; Minimum UID
    min_uid=100
    
    ; Minimum GID
    min_gid=100
    
    
    [handlers]
    ;Handler for php-scripts
    x-httpd-suphp=php:/usr/bin/php-cgi
    
    ;Handler for CGI-scripts
    x-suphp-cgi=execute:!self
    Suphp was installed before ISPConfig3 was installed. Any help with fixing this is greatly appreciated.
     
  2. parkerj

    parkerj Member HowtoForge Supporter

    Does anyone have an idea on how to get this working with suPHP? It works for mod fastcgi, but the php.ini file that it looks at is the wrong one.
     
  3. parkerj

    parkerj Member HowtoForge Supporter

    Nevermind, finally got it fixed.
     

Share This Page