Discussion in 'Installation/Configuration' started by Jcorrea920, Dec 8, 2006.

  1. Jcorrea920

    Jcorrea920 New Member

    So I have a problem with ISPConfig SSL Certs when we upgraded to IE7 on our desktops.

    So I tried this:

    openssl genrsa -des3 -passout pass:mypassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req -new -passin pass:mypassword -passout pass:mypassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req -x509 -passin pass:mypassword -passout pass:mypassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa -passin pass:mypassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
    as instructed by Falko at

    Then we added the new Certs to the Root Authority on each of our clients IE7 Certs. Seem to have solved the issue. Although...

    Is this bad?

    # tail /root/ispconfig/httpd/logs/error_log
    [Thu Dec  7 07:22:46 2006] [error] mod_ssl: SSL handshake failed: HTTP spoken on
     HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Thu Dec  7 07:22:46 2006] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GE
    T_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    Appreciate any help, as always. Thanks in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This message happens when you use http instead of https to connect to the controlpanel. This is nothing serious, the user get a page that tells him to use https.

Share This Page